Bug 217848 - overhead dependency to recode
overhead dependency to recode
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wbxml2 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Laurent Rineau
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 07:10 EST by Andy Shevchenko
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.2-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 07:54:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed spec changes (589 bytes, patch)
2006-11-30 07:10 EST, Andy Shevchenko
no flags Details | Diff

  None (edit)
Description Andy Shevchenko 2006-11-30 07:10:15 EST
Description of problem:
The wbxml2 requires the recode. I think this is overfull at least for Fedora 
due to iconv presence.

Version-Release number of selected component (if applicable):
Last official fe5 (I guess and other distros) release.

Additional info:
Please, apply attached patch.
Comment 1 Andy Shevchenko 2006-11-30 07:10:15 EST
Created attachment 142473 [details]
Proposed spec changes
Comment 2 Laurent Rineau 2006-11-30 09:21:48 EST
Thank you for your feedback and patch. Fixed in wbxml2-0.9.2-6.fc5, 
wbxml2-0.9.2-6.fc6, and wbxml2-0.9.2-6.fc7.

I have also modified 
http://fedoraproject.org/wiki/Packaging/CommonRpmlintIssues
Comment 3 Andy Shevchenko 2006-11-30 16:03:12 EST
Sorry, my mistake here. iconv can't changes file in place. Due to this the 
correct iconv call should be like following:
 /usr/bin/inconv -f ... -t ... $file > $file.conv && /bin/mv -f $file.conv 
$file

P.S. I've fixed wiki page already.
Comment 4 Laurent Rineau 2006-12-01 07:54:24 EST
Stupid of me! I should at least have checked that.

To bad that rpmlint no longer warns about non-UTF files. This time, I have 
check the generated files myself, and I have even found another fix to do:

Fix in this version:
* Fri Dec  1 2006 Laurent Rineau 
<laurent.rineau__fedora_extras@normalesup.org> - 0.9.2-8
- Stupidity. Fix the use of iconv. Bug #217848 again.
- Add an end-of-line to the file BUGS as well.

Note You need to log in before you can comment on or make changes to this bug.