Bug 21788 - Anaconda fail before reading packages during installation
Anaconda fail before reading packages during installation
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 21:55 EST by Kalil
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 10:42:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalil 2000-12-05 21:55:32 EST
Hi!

I wish to report this error which i encountered during installing RedHat 
Linux 7 (Guinness). It happened after while it setup was trying to read 
the packages from hard disk (after setting passwords). The reported error 
are as follows:

**********

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", 
line 33, in __call__
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: indexhtml

Local variables in innermost frame:
self: <comps.HeaderList instance at 82ef428>
item: indexhtml

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

**********

I was installing from hard disk. My configuration is as follows:

CPU: Intel Pentium 2 350Mhz
Mem: 128Mb
Hard Disk:
Primary Master: 14.2Gb
               |
               |-- windows ME (primary partition) - FAT32
               |
               |-- 2 logical drives in extended partition - FAT32
               |
               |-- windows 2000 prof. - NTFS
               |
               |-- linux mandrake 7.1 - Linux native + swap


Secondary Master: 6.4Gb
               |
               |-- Installation files for RH 7 (primary partition) - FAT16
               *   (max., i.e. 2047Mb) 
               |
               |-- // This is where RH7 is supposed to be!

* Note that I could not create linux partitions on the secondary partition 
when i had an extended FAT16 partition. I am puzzled by this actually.

I have also installed the anaconda update (update-disk-20001009.img) but 
to no use. The problem persisted.

Please let me know if there is a solution to this problem. Thank you.

Regards,
Kalil
Comment 1 Michael Fulbright 2000-12-06 10:42:39 EST
This is caused by a corrupt set of files in the install image on the hard disk.
Make sure you have used a binary safe method to download all the required files.

Note You need to log in before you can comment on or make changes to this bug.