Bug 217933 - AS5 beta open-iscsi initiator hard panic during login
AS5 beta open-iscsi initiator hard panic during login
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike Christie
Brock Organ
:
Depends On:
Blocks: 200812 217101
  Show dependency treegraph
 
Reported: 2006-11-30 15:13 EST by Hicham Hatime
Modified: 2009-06-19 06:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 20:09:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch supplied from LSI, Yanling.Qi@lsi.com (814 bytes, patch)
2006-12-16 12:13 EST, Andrius Benokraitis
no flags Details | Diff
fix senslen handling (1.49 KB, patch)
2006-12-18 12:50 EST, Mike Christie
no flags Details | Diff

  None (edit)
Description Hicham Hatime 2006-11-30 15:13:05 EST
Description of problem:

check-condition causes the kernel panic.
It seems the open-iscsi driver could not handle our check-condition sense-data 
format correctly.


Version-Release number of selected component (if applicable):
Distribution AS5 beta with the kernel version

2.6.18-1.2702.el5 #1 SMP Tue Sep 26 21:14:13 EDT 2006 x86_64 x86_64 x86_64 
GNU/Linux

Iscsi user space program rpm version

iscsi-initiator-utils-6.2.0.695-0.1

Kernel driver module

modinfo: could not find module tcp_iscsi
[root@localhost ~]# modinfo iscsi_tcp
filename:       /lib/modules/2.6.18-1.2702.el5/kernel/drivers/scsi/iscsi_tcp.ko
license:        GPL
description:    iSCSI/TCP data-path
author:         Dmitry Yusupov dmitry_yus@yahoo.com>, Alex Aizman 
itn780@yahoo.com>
srcversion:     D26EAA36E8A984A512D6DD4
depends:        libiscsi,scsi_transport_iscsi,scsi_mod
vermagic:       2.6.18-1.2702.el5 SMP mod_unload gcc-4.1
parm:           max_lun:uint

[root@localhost scsi]# modinfo libiscsi
filename:       /lib/modules/2.6.18-1.2702.el5/kernel/drivers/scsi/libiscsi.ko
license:        GPL
description:    iSCSI library functions
author:         Mike Christie
srcversion:     6AF60FC27D963DA2AD652A8
depends:        scsi_mod,scsi_transport_iscsi
vermagic:       2.6.18-1.2702.el5 SMP mod_unload gcc-4.1

[root@localhost scsi]# modinfo scsi_transport_iscsi
filename:       /lib/modules/2.6.18-
1.2702.el5/kernel/drivers/scsi/scsi_transport_iscsi.ko
version:        2.0-685
license:        GPL
description:    iSCSI Transport Interface
author:         Mike Christie michaelc@cs.wisc.edu>, Dmitry Yusupov 
dmitry_yus@yahoo.com>, Alex Aizman itn780@yahoo.com>
srcversion:     22F3047CF3908BF58F6E5A0
depends:        scsi_mod
vermagic:       2.6.18-1.2702.el5 SMP mod_unload gcc-4.1



How reproducible: High


Steps to Reproduce:
1.return a check-condition (06h/29h/00h) for a mode sense command
2.return a check-condition (05h/25h/00) for test unit ready. 
3.
  
Actual results:
Host panics

Expected results:
A successful login with a better handling of check-conditions.

Additional info:
Comment 1 Jay Turner 2006-12-01 15:39:41 EST
QE ack for RHEL5.
Comment 2 Samuel Benjamin 2006-12-13 14:02:35 EST
Requesting dev ack ...
Comment 3 Mike Christie 2006-12-13 23:06:07 EST
devel ack.
Comment 4 Andrius Benokraitis 2006-12-16 12:13:43 EST
Created attachment 143859 [details]
Patch supplied from LSI, Yanling.Qi@lsi.com

Mike, not sure you need this or not, but this is the patch LSI is proposing
that fixes this issue. Please contact Yangling directly on this.
Comment 5 Tom Coughlan 2006-12-16 12:50:48 EST
Changing component from kernel to iscsi-initiator-utils.
Comment 6 Mike Christie 2006-12-18 12:49:41 EST
Tom, this is a problem in the driver. For iscsi dirver problems from now on,
should we be using iscsi-initiator-utils? In the past we had only been using it
for the userspace iscsi component.
Comment 7 Mike Christie 2006-12-18 12:50:57 EST
Created attachment 143917 [details]
fix senslen handling

This is the patch we settled on upstream and I am sending to rh-kernel.
Comment 8 Tom Coughlan 2006-12-18 14:08:56 EST
Mike,

We should continue to use "kernel" for the driver, and "iscsi-initiator-utils"
for userspace. 

I moved this to userspace based on the patch in comment 4. Moving it back to kernel.

Tom
Comment 11 Don Zickus 2007-01-03 18:27:47 EST
in 2.6.18-1.2961.el5
Comment 13 yanling.qi@lsi.com 2007-01-23 12:24:23 EST
We verified the patch against 2.6.18-1.3002.e15. It works fine. Thanks for the 
good work.


Yanling Qi
Engenio Storage Group - LSI Logic
512-794-3713 (Office)
512-794-3702 (Fax)
yanling.qi@lsi.com
Comment 14 Amit Bhutani 2007-01-23 16:05:15 EST
Moving to VERIFIED based on Yanling's much awaited comment #13.
Comment 15 Andrius Benokraitis 2007-01-24 00:08:43 EST
Amit, we are now using the PartnerVerified keyword for verifying bugs. Setting a
bug to VERIFIED from MODIFIED may confuse the QE and errata systems. Setting
back to MODIFIED.
Comment 16 Amit Bhutani 2007-01-24 01:17:42 EST
Dell's agreement with the Larry, Kevin, Dave and Jay last month was for us
(Dell) to change status of issues to VERIFIED from MODIFIED if the package being
tested was a part of an official release such as a Snapshot Release. I've been
acting upon that agreed upon protocol.

Now, we did also discuss the usage of the keyword "PartnerVerified" as an over
and beyond. I have no problems sticking with the latter and not doing the former
described action, only I need confirmation that this is the preferred protocol
now for partners to reflect positive regression results.
Comment 17 Andrius Benokraitis 2007-01-24 09:57:52 EST
Amit, yes - the process is changing, I take it you all haven't been informed
about this since Larry is still on vacation.
Comment 18 RHEL Product and Program Management 2007-02-07 20:09:14 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.