Bug 217948 - switching tabs between list and others causes package metada reread
switching tabs between list and others causes package metada reread
Status: CLOSED DUPLICATE of bug 209923
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 16:06 EST by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 16:34:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2006-11-30 16:06:25 EST
Description of problem:

If you switch from list view to the other two as return back even immediately,
it causes a package metadata rereading. Pirut should cache this information and
not reread it unnecessarily. 

Additional info:

Also if you search for something in pirut and switch to any other view, the
search list is dropped. It might be better to have a explicit button for
clearing the search and retain it even if the user switches to another tab and
returns back
Comment 1 Jeremy Katz 2006-11-30 16:44:49 EST
We do things this way because otherwise, we'd have a non-trivial amount of work
to figure out what changed in the other view and reflect it in the list/search.
 We could maybe plug in something to not need to unless you've changed
something, but not sure how workable that really is.
Comment 2 Rahul Sundaram 2006-11-30 16:59:58 EST
Anything that user does in the search tab wouldnt affect the list view at all.
So switching to the search tab from the list tab and back should not cause any
metadata reread. 

In the browse tab, the user might have selected or unselected any packages but
unless the user has clicked the apply button, it shouldnt affect what the search
results or listing of packages. 

Its annoying that pirut rereads the metadata information and clears the search
results just because I switched views and did no package additional or removals
at all. 
Comment 3 Jeremy Katz 2006-11-30 20:24:29 EST
(In reply to comment #2)
> Anything that user does in the search tab wouldnt affect the list view at all.
> So switching to the search tab from the list tab and back should not cause any
> metadata reread. 

It's not just reading metadata, though; it's calculating package state to show
the right thing as far as available vs installed vs being removed, etc.

> Its annoying that pirut rereads the metadata information and clears the search
> results just because I switched views and did no package additional orremovals
> at all. 

Doing the alternative ends up being a huge memory hit...  I've got some ideas on
how to make things better, but it's a matter of time to get to trying them.
Comment 4 Jeremy Katz 2007-04-09 16:34:40 EDT

*** This bug has been marked as a duplicate of 209923 ***

Note You need to log in before you can comment on or make changes to this bug.