Bug 217988 - No sound on Toshiba Satellite A45-S120
No sound on Toshiba Satellite A45-S120
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 22:17 EST by Eli
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 19:04:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file from system-config-soundcard (40.49 KB, text/plain)
2006-11-30 22:17 EST, Eli
no flags Details

  None (edit)
Description Eli 2006-11-30 22:17:07 EST
Description of problem:
I'm not getting sound from the sound card.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2849.fc6

How reproducible:
Always

Steps to Reproduce:
1.  Run system-config-soundcard
2.  Test sound
3.
  
Actual results:
No sound

Expected results:
Sound :)

Additional info:
Toshiba Satellite A45-S120 notebook computer 
2.6Ghz Intel Celeron 
160GB hard drive 
CD-RW + DVD combo drive 
768MB RAM 
1024x768 LCD screen 
1 PC card slot 
4 USB ports 
1 built-in 100MB ethernet port 
1 parallel port 
1 VGA out
Comment 1 Eli 2006-11-30 22:17:07 EST
Created attachment 142540 [details]
Log file from system-config-soundcard
Comment 2 Eli 2006-11-30 22:19:09 EST
I recall getting sound during the initial install of the system.  I think I 
may have tested the modem sound output just for grins, but I don't expect 
anything from that.
Comment 3 Eli 2007-01-10 20:06:01 EST
I have since reinstalled FC6; sound worked during install, but did not work
after that.

Current kernel: kernel-2.6.18-1.2869.fc6
Comment 4 Eli 2007-01-20 16:54:08 EST
Still no sound with kernel-2.6.19-1.2895.fc6

Are there any other details I can provide to debug this?
Comment 5 Eli 2007-04-21 20:16:04 EDT
Still no sound with kernel-2.6.20-1.2944.fc6

What do I need to do to get someone to look at this?  Sound worked during
install, but does not work afterward.  This has been a problem since the FC4
timeframe.  I'm willing to provide additional info/test kernels/whatever.
Comment 6 Eli 2007-04-21 20:18:03 EDT
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to
I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet
Controller (rev 83)
01:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus
Bridge with ZV Support (rev 33)
Comment 7 Eli 2007-08-30 20:51:41 EDT
I was able to get sound working on this system.

Apparently the headphone detection is broken or something.  In KMix, under the
"Switches" tab, I clicked on "Headphone Jack Sense" to turn the yellow "light"
off.  Once I did that, sound works through the builtin speakers, and plugging
headphones disables the builtin speakers and sound comes through the headphones.

Note You need to log in before you can comment on or make changes to this bug.