Bug 2180 - DHCP client not receiving IP parameters
DHCP client not receiving IP parameters
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-14 13:05 EDT by scott.reimert
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-11 15:31:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scott.reimert 1999-04-14 13:05:56 EDT
PC is a Dell Latitude XPi CD with 32MB RAM. NIC is a 3COM
3C589 PCMCIA card (known good)

After reconfiguring kernel (modules and module version
checking enabled), DHCP client is non-functional. Modules
have been rebuilt/installed, pcmcia has been
recompiled/installed.

pcmcia services successfully load 3c589 driver.
message in /var/log/messages includes:
"Apr 14 01:46:34 nomad dhcpcd[351]: ioctl SIOCSIFBRDADDR
(ifconfig): Cannot assign requested address"

There is no /sbin/dhcpcd. /sbin/pump exists.

Network DHCP is known to functional and works on other
clients. Several addresses are available.

I read the related bug report on this topic, but it stated
that this had been fixed.
Comment 1 scott.reimert 1999-04-15 11:31:59 EDT
Forgot to add: I modified /etc/pcmcia/network.opts (Use DHCP="y"),
and although /sbin/pump exists, it's not in the process stack. When
started from the command line (/sbin/pump -i eth0) it immediatly
exits. /etc/dhcp does not exist.
Comment 2 scott.reimert 1999-04-16 15:19:59 EDT
When the system initially boots, no packets can go in or out. On
issuing /etc/rc.d/init.d/network reload, remote hosts can be pinged
by number. (DHCP is still not working).
Comment 3 scott.reimert 1999-04-16 17:33:59 EDT
ifconfig shows that ip address and netmask are actually being
determined correctly. Only DNS information is not being taken care
of. The DHCP server is known to be providing DNS information (name
servers, domain, etc.)
Comment 4 Anonymous 1999-05-13 23:31:59 EDT
PUMP is not working.

Default gateway parameter is not set properly so all routes using that
interface fail.
Replace references in 'ifup' and 'ifdown' of /sbin/pump to
/sbin/dhcpcd.  This corrects problem.

HW: Dell Latitude XPi using 3Com 'Vortex' driver - worked with RH5.2
SW: upgraded to 6.0 (via DOS DISK) couldn't get DHCP parms for ADSL
Modem so I wiped out the Linux Partition and loaded RH6.0 fresh.
System dual boots with LILO to Win98 so all HW known in good working
order.
Comment 5 David Lawrence 1999-06-11 15:31:59 EDT
This problem has been fixed in a the errata release of pump located at
ftp://updates.redhat.com/6.0/i386. Please obtain and install to see of
this fixes the problem for you. If not, please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.