Bug 21803 - System failure after formating /home
System failure after formating /home
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-06 10:14 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-05 17:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-06 10:14:47 EST
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in
doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 713, in
mountFilesystems
    raise SystemError, (errno, msg)
SystemError: (22, 'Invalid argument')

Local variables in innermost frame:
size: 358816
fsystem: ext2
self: <fstab.GuiFstab instance at 8447e20>
msg: Invalid argument
doFormat: 0
errno: 22
device: hda6
instPath: /mnt/sysimage
mntpoint: /home

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-12-06 10:44:35 EST
This is a dupe for bug 16686.

Could you please give us step by step instructions on how to reproduce this problem?
Comment 2 Need Real Name 2000-12-06 14:46:15 EST
The system: Dell Optilpex GXM 5166, the existing OS: RedHat 6.2 with / , /var ,/tmp , /boot  and swap. I intended to install the Redhat 7.0 with / , /boot, 
/usr, /home, /var and swap. During the packages selections the ldap was configured and NIF was enabled. 
This error message was showed at the Installing Packages screen.  After I clicked OK, the system was shut down and reboot itself. On the next try, I 
repeated the same configurations and the installer failed at the same spot with the same error message. Now I am trying to install the system again with 
the same partitions but without ldap, NIF and individule  Packages selection, so far the installer install the packages without any problems. 
WHy?
Comment 3 Need Real Name 2000-12-06 15:20:47 EST
Correction: not NIF its NFS, sorry the typo.
Comment 4 Michael Fulbright 2000-12-27 12:32:17 EST
Assigning to a developer.

Looks like bug 16686, has a test case however.
Comment 5 Brent Fox 2001-01-11 14:41:41 EST
Did installing without ldap, NFS, and individual package selection work?
Comment 6 Brent Fox 2001-01-11 14:44:57 EST
What is the make, model and capacity of the hard drive?
Comment 7 Brent Fox 2001-02-05 17:48:50 EST
Fixed in internal trees.

Note You need to log in before you can comment on or make changes to this bug.