Bug 218031 - general dependency error upgrading to fc6
general dependency error upgrading to fc6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libavc1394 (Show other bugs)
6
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Jarod Wilson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 08:39 EST by kballen
Modified: 2014-01-21 17:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 17:15:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kballen 2006-12-01 08:39:54 EST
Description of problem:
When upgrading from FC5 to FC6 using yum as per YumUpgradeFaq on the wiki, I 
encountered the following dependency error:
Transaction Check Error:   file /usr/lib64/libavc1394.so.0.3.0 from install of 
libavc1394-0.5.3-1.fc6 conflicts with file from package libavc1394_0-0.5.3-
0_9.fc5.at
  file /usr/lib64/librom1394.so.0.3.0 from install of libavc1394-0.5.3-1.fc6 
conflicts with file from package librom1394_0-0.5.3-0_9.fc5.at


Version-Release number of selected component (if applicable):
FC5, FC6

How reproducible:
Install FC5 x86-64.
Try to upgrade to FC6 using yum.
Comment 1 Jarod Wilson 2006-12-01 15:56:46 EST
Hrm, looks like you've got 3rd-party libavc1394/librom1394 bits from atrpms.net
in your FC5 install. So far as I can see, atrpms.net doesn't carry any
libavc1394/librom1394 bits for FC6, and the broken out libs from the FC5/atrpms
package aren't getting replaced by the FC6 libavc1394 package. Hrm.

I'd probably say 'yum remove libavc1394_0 librom1394_0', then 'yum install
libavc1394', or something along those lines. This isn't actually a libavc1394
bug, I think its an issue with the depsolver (yum) not liking the broken-out lib
packaging when trying to upgrade to a newer package that doesn't use broken-out
libs.
Comment 2 Jarod Wilson 2006-12-11 14:08:31 EST
I'm guessing this is wontfix or notabug (and should be taken up w/atrpms), but
I'll assign the bug over to yum and let the call be made there.
Comment 3 Jeremy Katz 2006-12-11 14:37:55 EST
There's nothing yum can do.  The libavc1394 packages we ship _could_ obsolete
those packages.
Comment 4 Jarod Wilson 2006-12-13 16:24:03 EST
Axel, any thoughts/suggestions on this issue?
Comment 5 Jarod Wilson 2006-12-13 16:25:03 EST
Whoops, didn't mean to close this...
Comment 6 Axel Thimm 2006-12-13 20:03:15 EST
There are three things I can do:

o keep a copy indefinitely in ATrpms (bad)
o promote soname-in-lib methology (currently not a good chance)
o ask for help
(http://www.redhat.com/archives/fedora-devel-list/2005-December/msg01345.html)

Jarod, could you please add to rawhide

Obsoletes: libavc1394_0 <= %{version}-%{release}, librpm1394_0 <=
%{version}-%{release}

I wouldn't push that as an update by itself, but if you'll update FC6/FC5 for
other reasons, please add the Obsoletes: line, thanks!
Comment 7 Jarod Wilson 2006-12-14 17:15:52 EST
(In reply to comment #6)
> Jarod, could you please add to rawhide
> 
> Obsoletes: libavc1394_0 <= %{version}-%{release}, librpm1394_0 <=
> %{version}-%{release}

Okay, FC6 and devel cvs has been updated to include this change. I've got
another libavc1394 bug that'll require a respin once I get to it, so the next
release will carry this update, closing accordingly.

Note You need to log in before you can comment on or make changes to this bug.