Bug 218037 - Trying to assign an non-existant file for block attach will leave device held forever.
Summary: Trying to assign an non-existant file for block attach will leave device held...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Glauber Costa
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-01 14:39 UTC by Glauber Costa
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-26 20:57:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch already merged upstream (1.18 KB, patch)
2006-12-01 14:49 UTC, Glauber Costa
no flags Details | Diff

Description Glauber Costa 2006-12-01 14:39:48 UTC
In some situations, like when error happens in block attach for
a guest in dom0, backend send us XenbusStateClosing notification.
However, as frontend were never properly initialized, it fails
to change its own state to XenbusStateClosed, leaving the system
in a dead-end state.

Steps to reproduce:
1 - pass a nonexistant file, like: 
xm block-attach <domId> file://nonexistant xvdb w
2 - xm block-list <domId> <== Will still be there
3 - xm block-detach <domId> <== Will still be there.

Comment 1 Glauber Costa 2006-12-01 14:49:18 UTC
Created attachment 142570 [details]
patch already merged upstream

fix it.

Comment 2 Rik van Riel 2006-12-03 18:07:13 UTC
The only ACK missing here is the QA ack, but since this bug is exceedingly easy
to test I'll apply the patch anyway :)

QA recipe:
1. configure an HVM guest's fda as /dev/fd0
2. try to boot the HVM guest

Without this patch, the Xen utilities refuse to create the guest.
With this patch, the Xen utilities should create the guest just fine.

Comment 3 Rik van Riel 2006-12-04 21:13:20 UTC
Oops, that was the wrong bugzilla yesterday!

Comment 4 Jay Turner 2006-12-06 22:51:17 UTC
QE ack for RHEL5.

Comment 5 Don Zickus 2006-12-06 23:04:34 UTC
in 2.6.18-1.2839.el5

Comment 6 Jay Turner 2007-01-26 20:57:19 UTC
2.6.18-7.el5 included in 20070125.0.


Note You need to log in before you can comment on or make changes to this bug.