Bug 218056 - Rhel 5 Virt test failed
Rhel 5 Virt test failed
Status: CLOSED DEFERRED
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Greg Nichols
Greg Nichols
:
: 218857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 11:24 EST by Garry Wong
Modified: 2007-04-18 13:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-17 12:50:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test results (1003.77 KB, application/octet-stream)
2006-12-01 11:24 EST, Garry Wong
no flags Details
ProLiant DL360 G5 test results (1003.77 KB, application/octet-stream)
2006-12-05 15:38 EST, Garry Wong
no flags Details
hts version 14 log (431.48 KB, application/x-zip-compressed)
2006-12-14 10:56 EST, Garry Wong
no flags Details
hts-14-virt log (357.34 KB, application/x-zip-compressed)
2006-12-15 12:15 EST, Garry Wong
no flags Details
hts 14 test suite (3.64 MB, application/x-zip-compressed)
2006-12-15 12:19 EST, Garry Wong
no flags Details
hts-14-virt log (359.06 KB, application/x-zip-compressed)
2006-12-18 15:08 EST, Garry Wong
no flags Details
Virt log (369.83 KB, application/x-zip-compressed)
2006-12-19 14:31 EST, Garry Wong
no flags Details
hts 15 virt log (380.45 KB, application/x-zip-compressed)
2007-01-10 10:27 EST, Garry Wong
no flags Details
virtlog (13.03 KB, application/x-zip-compressed)
2007-01-17 10:15 EST, Garry Wong
no flags Details
hts submit info (770.21 KB, application/octet-stream)
2007-01-17 10:16 EST, Garry Wong
no flags Details

  None (edit)
Description Garry Wong 2006-12-01 11:24:35 EST
Description of problem:

Rhel 5 Virt test failed even the intel system under test supports VT 

Version-Release number of selected component (if applicable):

Version-Release number of selected component (if applicable): rhel5 hts 
version 5 release 9


How reproducible:


Steps to Reproduce:
 1. Install rhel5 x86 beta2 with Virtualization capability onto system under 
test -ProLiant DL360 G5, and system under test DL360 G5 with VT enabled in BIOS
2. Install rhel5 x86 beta2 onto network test server
3. Install rhel5 hts version 5 release 9 test suite onto both system under 
test and network test server (with IPV4 status ip address 10.1.1.10)
4. On network test server ---> hts  server start
5. On system under test ----> hts plan ----> hts certify --test Virt --server 
10.1.1.10
 
Actual results: Failed

Expected results: Should pass


Additional info: See attached.
Comment 1 Garry Wong 2006-12-01 11:24:36 EST
Created attachment 142577 [details]
Test results
Comment 2 Greg Nichols 2006-12-05 14:15:46 EST
The virt test results from the attachment contain the log results:

Test Output:
Running ./virt.sh:
  This machine's ARCH is i686
  This machine has PAE 
 This machine has AMD's hardware support for virtualization : svm 
  Error ! You are running on a non-Xen kernel now ! 
  Please reboot to the right Xen kernel ! 
...finished running ./virt.sh, exit code=1

Was the xen kernel used for testing?
Comment 3 Garry Wong 2006-12-05 15:34:49 EST
I think you were looking from the wrong test results. This is Intel box, and 
xen kernel was used. The virt log should look like this:

Running ./virt.sh:
The directory /tmp/virt exists, will remove it now .
  This machine's ARCH is i686
  This machine has PAE 
  This machine has Intel's hardware support for virtualization : vmx 
  Hardware support for virtualization is enabled, start testing... 
  kickstart file successfully created ! 
[H[2J
  Following RHEL5 install media types are accepted: 
    o RHEL5 Server DVD iso image file 
    o RHEL5 Server OS file tree on the local disk 

  Press '1' if your install media is DVD iso image or 
  press '2' if your install media is OS file tree 
  Followed by the ENTER key ... 
[H[2J
  Where is the RHEL5 install DVD iso file ? 
  Please input the absolute dir , starting with '/' : 
  (A valid dir should looks like : /tmp/RHEL5-Server-20061020.1-i386-DVD.iso ) 
  Input your dir and press ENTER to continue ... 
INFO:	UTF-8 character encoding detected by locale settings.
	Assuming UTF-8 encoded filenames on source filesystem,
	use -input-charset to override.
Size of boot image is 4 sectors -> No emulation
Total translation table size: 2048
Total rockridge attributes bytes: 0
Total directory bytes: 2048
Path table size(bytes): 26
Max brk space used 0
3683 extents written (7 MB)
  boot iso successfully created ! 
  Creating Guest's hard drive file ... 
6000+0 records in
6000+0 records out
6291456000 bytes (6.3 GB) copied, 787.782 seconds, 8.0 MB/s
  Guest hd successfully created ! 
Shutting down NFS mountd: [60G[[0;31mFAILED[0;39m]
Shutting down NFS daemon: [60G[[0;31mFAILED[0;39m]
Shutting down NFS quotas: [60G[[0;31mFAILED[0;39m]
Shutting down NFS services:  [60G[[0;32m  OK  [0;39m]
Starting NFS services:  [60G[[0;32m  OK  [0;39m]
Starting NFS quotas: [60G[[0;32m  OK  [0;39m]
Starting NFS daemon: [60G[[0;32m  OK  [0;39m]
Starting NFS mountd: [60G[[0;32m  OK  [0;39m]
[H[2J
  This test will take many hours to finish ! 
  Please relax and be patient :-) 



Error: Disk image does not exist: /tmp/virt/virt1.img
Using config file "/etc/xen/localhost.localdomain-virt1".

  Guest OS is successfully created !! 
Error: Disk image does not exist: /tmp/virt/virt1.img
Using config file "/etc/xen/localhost.localdomain-virt1".

  Virtualization test finished !! 
cp: cannot stat `/tmp/virt/export/result/hts*.noarch.rpm': No such file or 
directory
ls: /tmp/virt/tmp/*: No such file or directory
  Unexpected Error ! No result rpm present ! 
...finished running ./virt.sh, exit code=1

173590864699216293169557564251986178823
Comment 4 Garry Wong 2006-12-05 15:38:31 EST
Created attachment 142887 [details]
ProLiant DL360 G5 test results

I am resending you the DL360 G5 test results.

Thanks,
Comment 5 YangKun 2006-12-05 22:16:07 EST
This problem is fixed in HTS5 release 13
Comment 6 Garry Wong 2006-12-14 10:56:28 EST
Created attachment 143644 [details]
hts version 14 log

The test still failed with hts version 14. See attached.

Also the "hts submit" and "hts print" commands are not working.

Thanks,
Comment 7 YangKun 2006-12-14 23:59:58 EST
the log shows that :

  Please specify where are the HTS related rpms, those you have installed 
  on the host machine: 
        -- hts    
        -- lmbench 
        -- stress  
        -- dt    


  Where is the 'hts' install rpm package ? 
  Please input the absolute dir , starting with '/' : 
  (A valid dir should looks like : /tmp/hts-VERSION-RELEASE.ARCH.rpm ) 
  Input the dir and press ENTER to continue ... 
./virt.sh: line 198: [: ==: unary operator expected
 Error ! The rpm file you specified is not correct ! 
 Please check the package again and restart this test ! 
  copy required rpm package error ! 
...finished running ./virt.sh, exit code=1


you must specify where the needed four rpm packages are. 
Comment 8 Garry Wong 2006-12-15 12:15:57 EST
Created attachment 143789 [details]
hts-14-virt log

I think I did, I typed /root/htsx64_U when prompted by the test. Unless some
rpms were missing the hts 14 test suite. I will attach the hts 14 package for
you to check if any missing rpm.

Thanks,
Comment 9 Garry Wong 2006-12-15 12:19:20 EST
Created attachment 143790 [details]
hts 14 test suite

Attached is my hts 14_x64 test suite package. Please check if there is any rpm
file missing.

Thanks,
Comment 10 Irina Boverman 2006-12-15 14:53:37 EST
You need to type entire path, including file name, when prompted for location of
the rpm. Did you include file name?
Comment 11 Garry Wong 2006-12-18 11:20:36 EST
No, I did not include the file name. Which rpm file do I need to include ?

Thanks,
Comment 12 Garry Wong 2006-12-18 15:08:05 EST
Created attachment 143939 [details]
hts-14-virt log

I typed in each hts rpms (hts, lmbench, dt, stress) as prompted, but the test
still fails (see attached 1.zip).

Thanks,
Comment 13 Garry Wong 2006-12-19 14:31:01 EST
Created attachment 144035 [details]
Virt log

Attached is latest virt run.

Thanks,
Comment 14 YangKun 2006-12-21 01:01:57 EST
*** Bug 218857 has been marked as a duplicate of this bug. ***
Comment 15 YangKun 2006-12-21 01:50:02 EST
some big changes are made on the virt test since hts-5.0-14, please wait for the
next release of hts, should be hts-5.0-15
Comment 16 Garry Wong 2007-01-10 10:27:35 EST
Created attachment 145260 [details]
hts 15 virt log

I installed hts 15 ----> ran virt test ---> still failed (see attached).

Note: The "hts submit" not working after hts certify --test virt" was ran.
Comment 17 YangKun 2007-01-10 21:46:02 EST
You are using RHEL5 RC snapshot5(kernel version : 2.6.18-1.2910), the anaconda 
shipped in this snapshot has a "kickstart-install" bug which will cause the 
VIRT test to fail. And this anaconda's bug is fixed in anaconda-11.1.2.28-1 . 
So please  wait for the next RC snapshot, or you can use a little bit older 
version of RHEL5(RHEL5-Server-20061207.4 , kernel version : 2.6.18-1.2839) to 
run the VIRT test if you are anxious to check it.
Comment 18 Garry Wong 2007-01-11 10:28:42 EST
Is it possible that you can send me the anaconda-11.1.2.28-1 so I can try ?

Thanks,
Comment 19 YangKun 2007-01-11 21:47:25 EST
In fact, this anaconda's bug only interferes the FV guest creation in the VIRT 
test. Which means it is OK to use RHEL5 RC snapshot5 as host OS and run the 
VIRT test on it, but remember to provide the the RHEL5-Server-20061207.4 DVD 
iso or install tree when VIRT test asks for install media.

It it not handy to manually replace/upgrade the anaconda package in the install 
media. I'm not sure whether this package replacement works or it may course 
other problems.
Comment 20 Garry Wong 2007-01-17 10:15:11 EST
Created attachment 145820 [details]
virtlog

-I used RHEL5 RC snapshot5 as host OS and run the VIRT test on it, and provided
the the RHEL5-Server-20061207.4 DVD iso or install tree when VIRT test asks for
install media, and I still got the failutre.

-After the test failed, the hts submit was not working (see attached txt)

-I had to delete /var/hts/results.xml then did "hts certify --test virt" to run
 hts submit (see attached later)
Comment 21 Garry Wong 2007-01-17 10:16:17 EST
Created attachment 145821 [details]
hts submit info
Comment 22 Greg Nichols 2007-01-17 12:50:48 EST
Deferred - virt test will not be used in this release.  FV guest set-up will be
done manually.
Comment 23 Garry Wong 2007-01-17 12:55:40 EST
 Do you have the steps document to set up FV guest manually ?

Thanks,

Comment 24 Greg Nichols 2007-01-17 13:04:09 EST
(In reply to comment #23)
>  Do you have the steps document to set up FV guest manually ?

We're updating the documentation to describe these steps.

Comment 25 Garry Wong 2007-01-17 13:10:33 EST
Deferred - virt test will not be used in this release ---> Please clarify 
which release.

Thanks,
Comment 26 Garry Wong 2007-01-17 17:51:11 EST
Would you please also clarify that if the virt test will be pulled out from 
the hts cert kit ?

Thanks,

Note You need to log in before you can comment on or make changes to this bug.