Bug 218062 - lshal: Applications must not close shared connections - see dbus_connection_close() docs. This is a bug in the application.
lshal: Applications must not close shared connections - see dbus_connection_...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 11:56 EST by Dan O'Brien
Modified: 2013-03-05 22:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 17:01:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan O'Brien 2006-12-01 11:56:55 EST
Description of problem:

lshal emits error message:

lshal >/dev/null
process 29945: Applications must not close shared connections - see
dbus_connection_close() docs. This is a bug in the application.

Version-Release number of selected component (if applicable):

hal-0.5.8.1-5.fc6

How reproducible:

Steps to Reproduce:
1. lshal >/dev/null
2.
3.
  
Actual results:

process 18206: Applications must not close shared connections - see
dbus_connection_close() docs. This is a bug in the application.


Expected results:


Additional info:
Comment 1 Matt Wette 2006-12-23 22:18:09 EST
I am getting the same error.  I believe this message started showing
up recently with the release of new dbus RPMs

# rpm -qa | grep dbus
dbus-x11-1.0.1-8.fc6
dbus-python-0.70-6
dbus-1.0.1-8.fc6
dbus-devel-1.0.1-8.fc6
dbus-glib-devel-0.70-6.fc6
dbus-glib-0.70-6.fc6

# rpm -qa | grep hal
hal-gnome-0.5.8.1-5.fc6
hal-0.5.8.1-5.fc6
hal-devel-0.5.8.1-5.fc6
hal-cups-utils-0.6.2-4.2
Comment 2 Tethys 2007-01-02 15:36:30 EST
Yep, and it's not just lshal, either:

leto:~% hal-device >/dev/null
process 8567: Applications must not close shared connections - see
dbus_connection_close() docs. This is a bug in the application.

leto:~% rpm -q hal dbus
hal-0.5.8.1-5.fc6
dbus-1.0.1-8.fc6
Comment 3 Adam Pribyl 2007-01-16 14:54:39 EST
Same here. x86_64 platform.
Comment 4 Patrice Dumas 2007-02-06 17:56:22 EST
It is certainly because lshal tries to close a shared dbus connection, 
like a connection to the SYSTEM bus. It is clearly forbidden here:

http://dbus.freedesktop.org/doc/api/html/group__DBusConnection.html#ge130c33da29477897d362ab89f068191

I hadn't a look at the hal code, though.
Comment 5 Marek Mahut 2007-02-17 09:09:41 EST
Same issue for me: 

hal-0.5.8.1-6.fc6
dbus-1.0.1-9.fc6

on different hw.
Comment 6 Patrice Dumas 2007-03-07 05:16:45 EST
This seems to be fixed now in devel
hal-0.5.9-0.git20070218.fc7
Comment 7 Chris Rivas 2007-05-01 09:13:35 EDT
I had the same problem with hal-0.5.8.1-6.fc6 and dbus-1.0.1-9.fc6.

This was fixed in hal upstream 2006-10-23.

dbus_connection_close(conn) was removed in one place in both lshal.c and
hal-device.c.

Afaik this still is not patched in FC6, although there have been 2 updates to
hal in FC6 since upstream fixed this.  
Comment 8 Patrice Dumas 2008-01-17 17:01:53 EST
Closing since this seems to be fixed in f7 and fc6 isn't 
supported anymore.

Note You need to log in before you can comment on or make changes to this bug.