Bug 218145 - SmartPM doesn't work with rpm-repackage option
Summary: SmartPM doesn't work with rpm-repackage option
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: smart   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-02 01:06 UTC by Igor Jagec
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 22:26:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Jagec 2006-12-02 01:06:01 UTC
Description of problem:

SmartPM doesn't work with rpm-repackage option

Version-Release number of selected component (if applicable):

$ rpmgrep smart
fedora-package-config-smart-6-8.i386
smart-0.42-40.fc6.i386
smart-gui-0.42-40.fc6.i386
smartmontools-5.36-3.i386

How reproducible:

Every time

Steps to Reproduce:
1. # smart upgrade -y
  
Actual results:

It fails to upgrade the system

Expected results:

To upgrade the system

Additional info:

#  smart upgrade -y
Loading cache...
Updating cache...               ######################################## [100%]

Computing transaction...
Committing transaction...                                                      
Preparing...                    ######################################## [  0%]

Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
  File "/usr/bin/smart", line 167, in main
    exitcode = iface.run(opts.command, opts.argv)
  File "/usr/lib/python2.4/site-packages/smart/interface.py", line 53, in run
    result = _command.main(self._ctrl, opts)
  File "/usr/lib/python2.4/site-packages/smart/commands/upgrade.py", line 182, 
in main
    ctrl.commitTransaction(trans, confirm=confirm)
  File "/usr/lib/python2.4/site-packages/smart/control.py", line 464, in 
commitTransaction
    return self.commitChangeSet(trans.getChangeSet(), caching, confirm)
  File "/usr/lib/python2.4/site-packages/smart/control.py", line 518, in 
commitChangeSet
    pmclass().commit(pmcs, pkgpaths)
  File "/usr/lib/python2.4/site-packages/smart/backends/rpm/pm.py", line 218, 
in commit
    probs = ts.run(cb, None)
  File "/usr/lib/python2.4/site-packages/smart/backends/rpm/pm.py", line 303, 
in __call__
    info, path = infopath
ValueError: too many values to unpack

[root@localhost igor]# smart config --set rpm-repackage=false

[root@localhost igor]#  smart upgrade -y
Loading cache...
Updating cache...               ######################################## [100%]

Computing transaction...
Committing transaction...                                                      
Preparing...                    ######################################## [  0%]
   1:Installing openssl         ######################################## [  7%]
   2:Cleaning openssl           ######################################## [ 14%]
   3:Installing dbus            ######################################## [ 21%]
   4:Cleaning dbus              ######################################## [ 28%]
   5:Installing freetype        ######################################## [ 35%]
   6:Cleaning freetype          ######################################## [ 42%]
   7:Installing hsqldb          ######################################## [ 50%]
   8:Cleaning hsqldb            ######################################## [ 57%]
   9:Installing gnome-session   ######################################## [ 64%]
  10:Cleaning gnome-session     ######################################## [ 71%]
  11:Installing dbus-x11        ######################################## [ 78%]
  12:Cleaning dbus-x11          ######################################## [ 85%]
  13:Installing freetype-devel  ######################################## [ 92%]
  14:Cleaning freetype-devel    ######################################## [100%]

Comment 1 Axel Thimm 2006-12-28 13:42:51 UTC
Filed upstream as http://tracker.labix.org/issue268

Comment 2 Axel Thimm 2007-02-07 09:11:54 UTC
Is this still an issue with 0.50?


Comment 3 Igor Jagec 2007-02-07 16:19:30 UTC
Yep :-/ Here's the output:

#smart upgrade -y
...
Traceback (most recent call last):
  File "/usr/bin/smart", line 194, in ?
    main(sys.argv[1:])
  File "/usr/bin/smart", line 167, in main
    exitcode = iface.run(opts.command, opts.argv)
  File "/usr/lib/python2.4/site-packages/smart/interface.py", line 53, in run
    result = _command.main(self._ctrl, opts)
  File "/usr/lib/python2.4/site-packages/smart/commands/upgrade.py", line 198, 
in main
    ctrl.commitTransaction(trans, confirm=confirm)
  File "/usr/lib/python2.4/site-packages/smart/control.py", line 505, in 
commitTransaction
    return self.commitChangeSet(trans.getChangeSet(), caching, confirm)
  File "/usr/lib/python2.4/site-packages/smart/control.py", line 563, in 
commitChangeSet
    pmclass().commit(pmcs, pkgpaths)
  File "/usr/lib/python2.4/site-packages/smart/backends/rpm/pm.py", line 218, 
in commit
    probs = ts.run(cb, None)
  File "/usr/lib/python2.4/site-packages/smart/backends/rpm/pm.py", line 303, 
in __call__
    info, path = infopath
ValueError: too many values to unpack

# smart config --set rpm-repackage=false
# smart upgrade -y
...
Preparing...                    ######################################## [  0%]
   1:Installing bzip2-libs      ######################################## [  1%]
...
  54:Installing beryl-gnome     ######################################## [ 98%]


Comment 4 Axel Thimm 2007-02-15 22:26:00 UTC
Please continue this report upstream on http://tracker.labix.org/issue268

Comment 5 Igor Jagec 2007-08-06 07:40:49 UTC
It seems the problem is solved. How can I apply the patch?
Thanks.

Comment 6 Igor Jagec 2007-08-06 07:42:11 UTC
I mean, the problem seems to be solved, but the update is not pushed into 
Fedora Updates, nor upstream as I can see. I saw the patch, but I don't know 
how to apply it. Thanks.

Comment 7 Axel Thimm 2007-08-06 08:56:25 UTC
Upstream is still evaluating it and hasn't given any blanket blessing for this
patch, so I don't want to introduce something in the package that may not be
compatible with what upstream will finally decide to implement.

If you need some starter help in diffing and patching try `info diff' and go to
Merging with `patch'.


Note You need to log in before you can comment on or make changes to this bug.