Bug 218157 - User-Hostile install error when HTTP files not located
User-Hostile install error when HTTP files not located
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 02:12 EST by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 13:47:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-12-02 02:12:28 EST
Description of problem:

Entire install halts with "Abort" the only option (which shuts down the 
install) when HTTP files are not found.  This is completely unnecessary, and 
horribly user-hostile.

Version-Release number of selected component (if applicable):

beta2

How reproducible:

always

Steps to Reproduce:
1. boot disc1
2. select HTTP install
3. enter an incorrect HTTP install folder
  
Actual results:

Message "Unable to read package metadata. etc"  
Only option: "Abort"

Expected results:

Message "Unable to read package metadata. etc"  
Options: "Retry", "Back", "Abort"

Additional info:
Comment 1 Chris Lumens 2007-02-28 13:47:26 EST
On additional repos that you've added, we do display an error message and let
you go back to correct the URL.  On the core repository, there's not really
anything we can do here.  Providing a retry option doesn't help most people,
since the repo they're installing from probably hasn't done anything to correct
the problem yet (especially if it's a CD - there's nothing that can be done
short of burning a new one).  Providing a back option doesn't help because
there's nothing you can do to correct a bad core repo.  We can provide a retry
option if we really need to, but it wouldn't do much except make the user feel
like there's something they can do.

Closing as CLOSED->RAWHIDE because error handling has gotten better here
overall.  If you need this sort of fix in an updated release of RHEL5, please
tell your support representative who will raise it through the appropriate channels.

Note You need to log in before you can comment on or make changes to this bug.