Bug 218165 - Size button in list inconsistent operation
Size button in list inconsistent operation
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 07:24 EST by Graham
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.0.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 06:41:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham 2006-12-02 07:24:37 EST
Description of problem:
If you click on the size button in the package list view to sort by size this
only seems to work for increasing size. If you click to switch between
increasing/decreasing/off the decreasing list doesn't seem to work.

Version-Release number of selected component (if applicable): 1.2.0

How reproducible: Seemingly very.

Steps to Reproduce:
1. Open yumex and refresh the repositories
2. Select "Remove" (not sure if it is specific to remove, but this is what I was
using)
3. Click on the size sorting button, and again, and again.
  
Actual results:
Switches between increasing and unsorted only.

Expected results:
Switch between increasing, decreasing and unsorted.

Additional info:
Not sure if this is in other areas of the list views, but I thought I would log
the bug against what I was actually doing so you have an example.

[graham@GrahamsDell ~]$ rpm -qi yum
Name        : yum                          Relocations: (not relocatable)
Version     : 3.0.1                             Vendor: Red Hat, Inc.
Release     : 2.fc6                         Build Date: Fri 10 Nov 2006 04:59:19
PM GMT
Install Date: Tue 21 Nov 2006 09:46:56 PM GMT      Build Host:
ia64-1.build.redhat.com
Group       : System Environment/Base       Source RPM: yum-3.0.1-2.fc6.src.rpm
Size        : 1870332                          License: GPL
Signature   : DSA/SHA1, Thu 16 Nov 2006 10:27:46 PM GMT, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>

[graham@GrahamsDell ~]$ rpm -qi python
Name        : python                       Relocations: (not relocatable)
Version     : 2.4.4                             Vendor: Red Hat, Inc.
Release     : 1.fc6                         Build Date: Mon 23 Oct 2006 07:02:53
PM BST
Install Date: Tue 21 Nov 2006 09:46:17 PM GMT      Build Host:
hs20-bc2-3.build.redhat.com
Group       : Development/Languages         Source RPM: python-2.4.4-1.fc6.src.rpm
Size        : 21630958                         License: PSF - see LICENSE
Signature   : DSA/SHA1, Mon 06 Nov 2006 08:15:51 PM GMT, Key ID b44269d04f2a6fd2
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
[root@GrahamsDell ~]# yumex&
[1] 3446
[root@GrahamsDell ~]# 12:06:54 : GUI Setup Completted
12:07:04 : Current Settings :
12:07:04 :     autocleanup: True
12:07:04 :     autorefresh: False
12:07:04 :     color_console: '#68228B'
12:07:04 :     color_pkgdesc: '#68228B'
12:07:04 :     debug: True
12:07:04 :     exclude: []
12:07:04 :     filelists: True
12:07:04 :     font_console: 'Monospace 8'
12:07:04 :     font_pkgdesc: 'Monospace 8'
12:07:04 :     fullobsoletion: False
12:07:04 :     mirrordetection: 'fastest'
12:07:04 :     nolauncher: False
12:07:04 :     noplugins: False
12:07:04 :     processsafemode: False
12:07:04 :     proxy: ''
12:07:04 :     recentdays: 14
12:07:04 :     updateonly: False
12:07:04 :     usecache: False
12:07:04 :     yumdebuglevel: 2
12:07:04 : Mirrordetection : fastest
12:07:04 : Yum Version : 3.0.1 (/usr/share/yum-cli)
Comment 1 Austin 2006-12-12 20:04:36 EST
I just checked this against an update (today's) and can verify that it's the
same problem in the update pane. It will only sort in decreasing size values.
Toggling it to increasing generates a random (?) list, and turning it "off"
doesn't restore the previous "sort" method (alpha by name?).

This is also using yumex v1.2.0
Comment 2 Simon Gustafsson 2007-03-03 16:10:13 EST
yumex-1.2.2-1.0.fc6 don't sort correctly the first times "size" is pressed, but
after pressing it several times, the sorting strangely starts to work correctly.
I also noted that yumex crashes if I messes with sorting of the size column and
then did a couple of additional steps. I filed that as a separate bug (bug #230859).
Comment 3 Tim Lauridsen 2007-09-28 06:41:25 EDT
I have removed the "click on column" sort in current version of yumex 2.0.x,
because of it make the view update to slow, and cause to many problems, so i
will close this bug.
Comment 4 Graham 2007-09-29 01:23:41 EDT
The ability to sort is a very useful function and will be missed
Comment 5 Austin 2007-09-30 09:59:40 EDT
(In reply to comment #4)
> The ability to sort is a very useful function and will be missed

Concur with that! :-/

Note You need to log in before you can comment on or make changes to this bug.