Bug 218166 - eaccelerator breaks PHP 5.2.0
Summary: eaccelerator breaks PHP 5.2.0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: php-eaccelerator   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-02 12:57 UTC by Richard Körber
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 5.2.0_0.9.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 11:48:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Körber 2006-12-02 12:57:17 UTC
Description of problem:
After upgrading to PHP 5.2.0, eaccelerator breaks websites that require PHP5
class features, like Mediawiki. An error "Cannot access protected property" is
thrown instead. After uninstalling eaccelerator, the site works fine again.

Version-Release number of selected component (if applicable):
php-eaccelerator-5.2.0_0.9.5-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Update to PHP 5.2.0
2. Install php-eaccelerator
3. Invoke a site that requires PHP5 features, e.g MediaWiki.
  
Actual results:
PHP execution fails with an "Cannot access protected property" error if the site
uses PHP5 features (e.g. MediaWiki: "Cannot access protected property
OutputPage::$mParserOptions").

Expected results:
PHP execution should not fail.

Additional info:
This is a known eaccelerator bug, see: http://eaccelerator.net/ticket/204

Comment 1 Matthias Saou 2006-12-04 09:52:41 UTC
Packages of 5.2.0_0.9.5-2.fc7 are being rebuilt. Let me know if the problems are
fixed since they're available.

Comment 2 Richard Körber 2006-12-07 09:51:12 UTC
5.2.0_0.9.5-2.fc7 fixes that bug for me. Thank you!

Comment 3 Matthias Saou 2006-12-11 11:48:20 UTC
Changing component back from 915resolution to php-eaccelerator. Seems like it
was changed by mistake with the last comment.


Note You need to log in before you can comment on or make changes to this bug.