Bug 218169 - pvmove fails and lvm commands hang
pvmove fails and lvm commands hang
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 08:46 EST by D Sundqvist
Modified: 2008-05-01 11:39 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 16:10:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D Sundqvist 2006-12-02 08:46:21 EST
Description of problem:

pvmove fails with these error messages:

[root@localhost ~]# pvmove -n test1 /dev/xvdb1 /dev/xvdc1
  device-mapper: reload ioctl failed: Invalid argument
  ABORTING: Temporary mirror activation failed.  Run pvmove --abort.
  device-mapper: reload ioctl failed: Invalid argument
  device-mapper: reload ioctl failed: Invalid argument
[root@localhost ~]# 

[root@localhost ~]# tail /var/log/messages
Dec  2 13:24:35 localhost smartd[1654]: smartd has fork()ed into background
mode. New PID=1654. 
Dec  2 13:40:58 localhost kernel: device-mapper: mirror log: unrecognised sync
argument to mirror log: 2
Dec  2 13:40:58 localhost kernel: device-mapper: table: 253:2: mirror: Error
creating mirror dirty log
Dec  2 13:40:58 localhost kernel: device-mapper: ioctl: error adding target to table

After the attempted and failed pvmove, lvm commands (vgdisplay, pvmove --abort,
etc) will no longer return, but hang indefinitely.

Rebooting the system will allow a pvmove --abort and lvm commands will work again.


Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qa device-mapper
device-mapper-1.02.07-3
kernel 2.6.18-1.2798.fc6xen and 2.6.18-1.2849.fc6xen


How reproducible:
Always

Steps to Reproduce:
1. Install fedora core
2. Create a new volume group with two disks. Create a lv on one of the disks.
3. pvmove lv from disk 1 to disk 2
  
Actual results:
pvmove fails with previously listed errors.

Expected results:
pvmove completes successfully.

Additional info:
The problem is essentially the same as bug #205818; however, as that bug is
listed explicitly on rawhide and I can see no indications of intent to
move/expand to FC6 for at least a month, nor packages in testing, I'm
registering this bug on FC6.

Further, manually upgrading (download and compile from source) device-mapper to
device-mapper.1.02.08, which was apparently the resolution of this particular
problem in the debian bug report mentioned in the aforementioned bug, appears to
solve this particular issue.
Comment 1 Ask Bjørn Hansen 2006-12-18 04:41:32 EST
FWIW, upgrading to the latest device-mapper fixed the problem for me, too.

Since LVM is used in the default install it's curious that Fedora would let this slip.  :-/


 - ask
Comment 2 Jason Farrell 2006-12-18 05:16:31 EST
rawhide's device-mapper has fixed this issue in FC6 for me as well. I can now
finally use pvmove again, without locking lvm up, in order to clear specific
partitions for multiboot installs.

Installed Packages
device-mapper.i386                       1.02.07-3              installed
Available Packages
device-mapper.i386                       1.02.13-1.fc7          development
[root@nano ~]# yum --enablerepo=development update device-mapper
Comment 3 Alasdair Kergon 2006-12-18 05:28:19 EST
OK - let's go ahead and release that and lvm2 2.02.17 in the older fc updates.
Comment 4 LVM and device-mapper development team 2007-01-04 09:29:55 EST
dm/lvm2 packages built (cluster not done yet)
Comment 5 Fedora Update System 2007-01-10 15:28:13 EST
lvm2-2.02.17-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2007-01-22 12:03:06 EST
lvm2-2.02.17-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 7 Corey Marthaler 2007-01-24 16:02:51 EST
Fix verified in lvm2-2.02.19-1.el4.

[root@link-08 ~]# pvmove -n test1 /dev/sda1 /dev/sdc1
  /dev/sda1: Moved: 100.0%

Note You need to log in before you can comment on or make changes to this bug.