Bug 218177 - No display with latest FC6 errata and the radeon driver
No display with latest FC6 errata and the radeon driver
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 12:34 EST by Dave Russell
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 09:39:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log with no display (59.73 KB, text/plain)
2006-12-02 12:34 EST, Dave Russell
no flags Details
display working with the vesa driver (56.91 KB, text/plain)
2006-12-02 12:36 EST, Dave Russell
no flags Details
dmesg output (14.95 KB, text/plain)
2006-12-02 12:38 EST, Dave Russell
no flags Details
lspci output (1.07 KB, application/octet-stream)
2006-12-02 12:39 EST, Dave Russell
no flags Details
modified xorg.conf with some radeon specific tweaks to try and make things work (771 bytes, text/plain)
2006-12-03 05:36 EST, Dave Russell
no flags Details
xorg log file with rawhide rpms (58.05 KB, application/octet-stream)
2006-12-03 05:36 EST, Dave Russell
no flags Details
xorg.conf file as used to generate the recent log messages (600 bytes, text/plain)
2006-12-03 06:10 EST, Dave Russell
no flags Details
latest xorg.log generated with debuginfo rpms in place (59.45 KB, text/plain)
2006-12-03 06:11 EST, Dave Russell
no flags Details

  None (edit)
Description Dave Russell 2006-12-02 12:34:52 EST
Description of problem:

Following recent updates (unfortunately not sure exactly which ones caused this)
my machine no longer has any display when using the radeon driver.

The machine boots, I see the first boot, then the virtual terminal, but I never
see the X login prompt, at this point I am unable to switch to a VT, so I assume
that the machine has locked hard at this point.

Version-Release number of selected component (if applicable):

I've listed most of the xorg rpms (minus inappropriate drv rpms)

xorg-x11-twm-1.0.1-3.1
xorg-x11-fonts-100dpi-7.1-2
xorg-x11-xkb-utils-1.0.2-2.1
xorg-x11-xauth-1.0.1-2.1
xorg-x11-utils-7.1-2.fc6
xorg-x11-fonts-base-7.1-2
xorg-x11-fonts-Type1-7.1-2
xorg-x11-xinit-1.0.2-15.fc6
xorg-x11-drv-ati-6.6.3-1.fc6
xorg-x11-font-utils-7.1-2
xorg-x11-server-utils-7.1-4.fc6
xorg-x11-drv-vesa-1.2.1-4
xorg-x11-xfs-1.0.2-3.1
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2
xorg-x11-drivers-7.1-3
xorg-x11-apps-7.1-3.fc6
xorg-x11-fonts-misc-7.1-2


How reproducible:

Every time :o(

Steps to Reproduce:
1. Fresh install of FC6 (no upgrade and no ATI fglrx binary drivers ever installed)
2. X with the radeon driver works
3. update to the latest errata with "yum update -y"
5. Reboot and watch X fail to start
  
Actual results:

No x display using the radeon driver. It is possible to get a display using the
vesa driver, but it does not support the resolution of my widescreen monitor.

Expected results:

Should have a display.

Additional info:

will attach xorg logs, lspci and anything else that could be useful.
Comment 1 Dave Russell 2006-12-02 12:34:52 EST
Created attachment 142664 [details]
xorg log with no display
Comment 2 Dave Russell 2006-12-02 12:36:49 EST
Created attachment 142665 [details]
display working with the vesa driver
Comment 3 Dave Russell 2006-12-02 12:38:23 EST
Created attachment 142666 [details]
dmesg output
Comment 4 Dave Russell 2006-12-02 12:39:20 EST
Created attachment 142667 [details]
lspci output
Comment 5 Dave Russell 2006-12-03 05:07:16 EST
Forgot to mention:
xorg-x11-drv-ati-6.6.3-1.fc6

Am going to try updating xorg-x11-drv-ati from rawhide (plus deps)

Will also try rawhide kernel if still no change.
Comment 6 Dave Russell 2006-12-03 05:19:03 EST
Have updated the packages listed below from rawhide:

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 xorg-x11-drv-ati        i386       6.6.3-1.fc7      development       345 k
 xorg-x11-server-Xorg    i386       1.1.1-54.fc7     development       3.0 M

No rawhide kernel available at this time.
Comment 7 Dave Russell 2006-12-03 05:36:08 EST
Created attachment 142676 [details]
modified xorg.conf with some radeon specific tweaks to try and make things work

Still no joy with the rawhide packages, uploaded modified xorg.conf that I'm
currently using and xorg log file.
Comment 8 Dave Russell 2006-12-03 05:36:39 EST
Created attachment 142677 [details]
xorg log file with rawhide rpms
Comment 9 Dave Russell 2006-12-03 05:55:17 EST
Installed following packages from rawhide:

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
xorg-x11-drv-ati-debuginfo i386    6.6.3-1.fc7     development-debuginfo  2.0 M
xorg-x11-server-debuginfo  i386    1.1.1-54.fc7    development-debuginfo   39 M

Final test reboot with debuginfo packages in place, will post log files etc.
Comment 10 Dave Russell 2006-12-03 06:10:08 EST
Created attachment 142678 [details]
xorg.conf file as used to generate the recent log messages
Comment 11 Dave Russell 2006-12-03 06:11:31 EST
Created attachment 142679 [details]
latest xorg.log generated with debuginfo rpms in place
Comment 12 Bastien Nocera 2006-12-05 04:54:07 EST
Take a look in your /var/log/messages for avc messages, or try disabling SELinux
with system-config-securitylevel.
Comment 13 Bastien Nocera 2006-12-05 05:07:39 EST
Apparently, SELinux wasn't enabled.

I asked for the radeon DRI to be disabled, adding the line:
alias radeon off
to /etc/modprobe.conf and rebooting
Comment 14 Dave Russell 2006-12-05 05:11:19 EST
[root@luggage ~]# sestatus
SELinux status:                 disabled
[root@luggage ~]#

It's not selinux, and from the look of it, an aborted lockup has this footprint
in /var/log/messages

Dec  3 10:58:03 luggage smartd[2798]: smartd version 5.36
[i686-redhat-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Dec  3 10:58:03 luggage smartd[2798]: Home page is
http://smartmontools.sourceforge.net/
Dec  3 10:58:03 luggage smartd[2798]: Opened configuration file /etc/smartd.conf
Dec  3 10:58:03 luggage smartd[2798]: Configuration file /etc/smartd.conf parsed.
Dec  3 10:58:03 luggage smartd[2798]: Device: /dev/hda, opened
Dec  3 10:58:04 luggage smartd[2798]: Device: /dev/hda, found in smartd database.
Dec  3 10:58:04 luggage smartd[2798]: Device: /dev/hda, is SMART capable. Adding
to "monitor" list.
Dec  3 10:58:04 luggage smartd[2798]: Monitoring 1 ATA and 0 SCSI devices
Dec  3 10:58:05 luggage smartd[2800]: smartd has fork()ed into background mode.
New PID=2800.
Dec  3 10:58:06 luggage pcscd: winscard.c:219:SCardConnect() Reader E-Gate 0 0
Not Found
Dec  3 10:58:06 luggage last message repeated 3 times
Dec  3 10:58:06 luggage kernel: [drm] Initialized drm 1.0.1 20051102
Dec  3 10:58:06 luggage kernel: ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16
(level, low) -> IRQ 185
Dec  3 10:58:06 luggage kernel: [drm] Initialized radeon 1.25.0 20060524 on minor 0
Dec  3 10:58:07 luggage kernel: agpgart: Found an AGP 2.0 compliant device at
0000:00:00.0.
Dec  3 10:58:07 luggage kernel: agpgart: Putting AGP V2 device at 0000:00:00.0
into 1x mode
Dec  3 10:58:07 luggage kernel: agpgart: Putting AGP V2 device at 0000:01:00.0
into 1x mode
Dec  3 10:58:08 luggage kernel: [drm] Setting GART location based on new memory map
Dec  3 10:58:08 luggage kernel: [drm] Loading R300 Microcode
Dec  3 10:58:08 luggage kernel: [drm] writeback test succeeded in 1 usecs


The next line is...
Dec  3 11:00:37 luggage syslogd 1.4.1: restart.

Which is the first line of booting up.
Comment 15 Bastien Nocera 2006-12-05 05:29:57 EST
Putting on needinfo re comment #13
Comment 16 Dave Russell 2006-12-09 11:38:04 EST
Yup, that gets me a display.

So, what has changed in the last ~4-5 weeks that would have broken DRI with the
radeon driver?
Comment 17 Dave Russell 2007-02-02 09:39:02 EST
Well I've ditched this hardware (never did completely solve the problem) and
opened up a new bug, with widescreen displays on intel gfx hardware.

Marking this bug as closed (deferred) due to no longer having the hardware to test.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=226978

Note You need to log in before you can comment on or make changes to this bug.