Bug 21818 - When Installing 2100S in Redhat Version 7.0 Fails near end of installation
Summary: When Installing 2100S in Redhat Version 7.0 Fails near end of installation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-06 19:10 UTC by Carle C Cote
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 21:02:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carle C Cote 2000-12-06 19:10:53 UTC
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1630, in 
doInstall
    self.copyExtraModules()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1348, in 
copyExtraModules
    os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
fromFile: /mnt/sysimage/lib/modules/2.2.16-22smp/dpt_i2o.o
kernelVersions: ['2.2.16-22smp', '2.2.16-22']
path: /tmp/modules/dpt_i2o
names:  dpt_i2o.o dpt_i2o.o
command: cd /mnt/sysimage/lib/modules; gunzip 
< /tmp/modules/dpt_i2o/modules.cgz | /mnt/sysimage/bin/cpio  --quiet -
iumd  2.2.16-22smp/dpt_i2o.o 2.2.16-22/dpt_i2o.o
version: 2.2.16-22
subdir: scsi
to: /mnt/sysimage/lib/modules/2.2.16-22smp/scsi/dpt_i2o.o
n: 2.2.16-22smp
self: <todo.ToDo instance at 820c1b0>
pattern:  2.2.16-22smp/dpt_i2o.o 2.2.16-22/dpt_i2o.o
name: dpt_i2o

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'currentDisc'
p6
I2
sS'tree'
p7
S'/mnt/source'
sS'device'
p8
S'hda'
sS'progressWindow'
p9

<failed>

Comment 1 Michael Fulbright 2000-12-06 23:11:42 UTC
Please give a step by step description of how to reproduce this problem.

Comment 2 Carle C Cote 2000-12-07 01:39:53 UTC
Installing via linux dd.Installing from CD.
Adaptec has provided driver.2100S is SCSI Raid card.
Load driver when requested.OS load requested floppy.
Driver loads and we carry on with install.We can configure DiskDruid.
Can select any setup option.Set this one for custom server I believe.

System will format drives.Copy install files and make config changes near end 
of installation.It will be at 99 percent and then its game over.

Interesting thing is if I reboot it will indicate NO OS on drive.I am pretty 
sure it is the driver from Adaptec perhaps because I can fdisk /mbr with Dos 
and make drive bootable.


Comment 3 Michael Fulbright 2000-12-08 21:02:40 UTC
I'm not sure what kind of module the vendor supplied, but it is not a kernel
module that we shipped.  Perhaps the driver disk which the vendor supplied is
corrupt.


Note You need to log in before you can comment on or make changes to this bug.