Bug 218187 - sylpheed-claws does not start when IMAP server is unavailable
sylpheed-claws does not start when IMAP server is unavailable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sylpheed-claws (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 16:55 EST by Till Maas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 04:32:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2006-12-02 16:55:41 EST
Description of problem:
When I first start sylpheed-claws it shows a wizard to configure it. The wizzard
does not allow to use a non default port for IMAP, but my IMAP server listens on
port 10143. When I finish the wizard sylpheed-claws displays it cannot connect
to my IMAP server, which is true and then suggests that it might be some
out-of-date plugins and quits.

Error Message:
Sylpheed-Claws has detected a configured mailbox, but could not load it. It is
probably provided by an out-of-date external plugin. Please reinstall the plugin
and try again.

Since it won't start I cannot change the port of the IMAP server and therefore
it won't start.

Version-Release number of selected component (if applicable):
2.6.0-1

How reproducible:
always

Steps to Reproduce:
1. mv ~/.sylpheed-claws/  .sylpheed-claws-bak
2. run sylpheed-claws and configure it with an imap server it cannot connect
because of a wrong port
  
Actual results:
sylpheed-claws quits

Expected results:
sylpheed-claws provides a way to configure it properly / change the server
configuration when the servers cannot be reached
Comment 1 Colin Leroy 2006-12-08 16:57:32 EST
as a workaround, once it has quit, you can edit ~/.sylpheed-claws/accountrc and
set the correct port there... It's indeed a problem, though.
Comment 2 Andreas Bierfert 2006-12-09 12:31:24 EST
Opened upstream bug
http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1077
Comment 3 Andreas Bierfert 2006-12-18 04:32:12 EST
Fixed upstream. Will close this here as UPSTREAM. Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.