Bug 218246 - unable to start console
Summary: unable to start console
Status: CLOSED NEXTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Unknown   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-04 04:13 UTC by Andrew Anderson
Modified: 2015-01-04 23:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 14:59:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Anderson 2006-12-04 04:13:13 UTC
Description of problem: This is the error I get when I try to start the console.
GC Warning: Out of Memory!  Returning NIL!
Exception in thread "main" GC Warning: Out of Memory!  Returning NIL!
java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
*** Got java.lang.OutOfMemoryError while trying to print stack trace

Version-Release number of selected component (if applicable):7.1


How reproducible:Everytime


Steps to Reproduce:
1../startconsole
2.
3.
  
Actual results:
GC Warning: Out of Memory!  Returning NIL!
Exception in thread "main" GC Warning: Out of Memory!  Returning NIL!
java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
*** Got java.lang.OutOfMemoryError while trying to print stack trace

Expected results:


Additional info:

Comment 1 Rich Megginson 2006-12-04 16:20:39 UTC
What version of java are you using?
which java
You must use either the Sun or IBM JRE with the console - see 
http://directory.fedora.redhat.com/wiki/Install_Guide#Java_is_required_for_the_console

Comment 2 Andrew Anderson 2006-12-04 16:57:22 UTC
 Java(TM) 2 Runtime Environment, Standard Edition 1.4.2_13

Comment 3 Rich Megginson 2006-12-04 17:09:44 UTC
Hmm - What is your OS and version?  Are you using Fedora DS 7.1?  If so, you
also have to set JAVA_HOME to point to your java.  And I suggest using Fedora DS
1.0.4 instead of 7.1.

Comment 4 Andrew Anderson 2006-12-04 17:30:56 UTC
using Fedora DS 1.0.4
Fedora 5
did do the java_home

Comment 5 Rich Megginson 2006-12-04 17:36:59 UTC
Well, I'm not sure what the problem is.  The error shows very clearly that
startconsole is attempting to use gcj.  The Sun or IBM java must come in your
PATH before the gcj one.  If you want your /usr/bin/java to be the sun or ibm
one, please read http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4

Comment 6 Andrew Anderson 2006-12-04 18:09:01 UTC
Which part of the artical?
http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4



Comment 7 Rich Megginson 2006-12-04 18:17:03 UTC
(In reply to comment #6)
> Which part of the artical?
> http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4

Well, the whole thing, really.  You have to install the rpmdevtools in order to
build an RPM from the Sun java distro.

But you can just skip that.  The important thing is that the Sun java command is
in your PATH before /usr/bin/java in order for startconsole to work.

Comment 8 Andrew Anderson 2006-12-08 03:29:38 UTC
Start Slapd Starting Slapd server reconfiguration.
Info Slapd No old nsperl references found
Configuring Administration Server...
InstallInfo: Apache Directory "ApacheDir" is missing.

You can now use the console.  Here is the command to use to start the console:
cd /opt/fedora-ds
./startconsole -u admin -a http://FDSDC1.watchdog.local:21723/

Got this when I did setup again. Still unable to start console but am able to
got to url. Did go to through linking java to mozilla but when I try a java web
page mozilla crahes.

Here is what is in setup.log

Late-breaking news and information on the Fedora Directory Server is
available at the following location:

    http://directory.fedora.redhat.com
Continue? (yes/no) yes
Converting slapd-FDSDC1 to new format password file . . .
Copying new schema ldiffiles . . .
Starting slapd-FDSDC1 . . .

NMC_ErrInfo:
NMC_STATUS: -2

Start Slapd Starting Slapd server reconfiguration.
Info Slapd No old nsperl references found
Configuring Administration Server...
InstallInfo: Apache Directory "ApacheDir" is missing.
You can now use the console.  Here is the command to use to start the console:
cd /opt/fedora-ds
./startconsole -u admin -a http://FDSDC1.watchdog.local:21723/
INFO Finished with setup, logfile is setup/setup.log


Comment 9 Rich Megginson 2006-12-08 04:07:13 UTC
> Got this when I did setup again. Still unable to start console but am able to
> got to url. Did go to through linking java to mozilla but when I try a java web
> page mozilla crahes.

I'm not sure what you mean by "java web page".  Are you still getting the
"java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit"
error?


Note You need to log in before you can comment on or make changes to this bug.