Bug 21827 - The HTML/DocBook DTDs are not parsed by PSGML
The HTML/DocBook DTDs are not parsed by PSGML
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: xemacs (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-06 16:19 EST by vigna
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-12 14:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vigna 2000-12-06 16:19:39 EST
There are serious problems with SGML support in XEmacs. In a standard 7.0
installation, the request to parse the HTML DTD for a 4.0 Transitional
document
gives the following output:

/usr/lib/xemacs/xemacs-packages/etc/psgml/HTMLlat1.ent line 12 col 22
entity HTMLlat1
/usr/lib/xemacs/xemacs-packages/etc/psgml/html-4l.dtd line 172 col 10
entity HTML
/home/vigna/esercizi2.html line 1 col 105 
Delimiter MDC (>) expected; at: " " -- 

If I try to do the same for a DocBook 3.1 document, the result is

External entity ARTICLE not found
  Public identifier -//OASIS//DTD DocBook V3.1//EN

To fix this, I can try to do manually explain where to find the DocBook
files (in previous releases they where included in PSGML) with 

export
SGML_CATALOG_FILES="/usr/lib/sgml/CATALOG:/usr/lib/xemacs/xemacs-packages/etc/psgml/CATALOG"

and, as a result, trying to Parse the DTD of a DocBook document I get

/usr/lib/sgml/ISOamsa line 11 col 22 entity ISOamsa
/usr/lib/sgml/dbcent.mod line 54 col 9 entity dbcent
/usr/lib/sgml/docbook.dtd line 69 col 8 entity ARTICLE
/home/vigna/sgml/bsdel/bsdel.sgml line 1 col 57 
Delimiter MDC (>) expected; at: "[cularr]"--


Essentially, SGML support is completely unusable. HTML validation never
worked, but the DTD was parsed. DocBook validation and DTD parsing always
worked (with some tweaking), now they don't.
Comment 1 Trond Eivind Glomsrxd 2000-12-12 14:00:12 EST
Can you try xemacs-21.1.12-12 from the soon-to-be-refreshed Rawhide? I don't
have any problems with the html 4 transitional DTD, I'm trying to find a docbook
document to check that.
Comment 2 Trond Eivind Glomsrxd 2000-12-13 11:45:13 EST
OK, docbook had some problems (psgml wanted so save the now compiled DTD into a
site directory, something it isn't allowed to do) but it should be fixed in
21.1.12-13 coming soon to a Rawhide near you.
Comment 3 vigna 2001-05-01 13:13:24 EDT
I'm trying again in 7.1, but without success. nsgml (invoked with CTRL-c-v)
complains as follows with a valid HTML 4.01 document:

nsgmls -s -m /usr/lib/xemacs/xemacs-packages/etc/psgml/CATALOG
/usr/lib/xemacs/xemacs-packages/etc/psgml/html.decl gusti.html
nsgmls:/usr/lib/xemacs/xemacs-packages/etc/psgml/CATALOG:101:0:W: DTDDECL
catalog entries are not supported
nsgmls:/usr/lib/xemacs/xemacs-packages/etc/psgml/CATALOG:102:0:W: DTDDECL
catalog entries are not supported
nsgmls:/usr/lib/xemacs/xemacs-packages/etc/psgml/CATALOG:103:0:W: DTDDECL
catalog entries are not supported
......
Numerous error messages related to ISO-8859-1/Unicode characters follow.

With docbook it seems to find the DTD, and CTRL-c-v sort of works (complaining
about the DTDDECL entries as above), but then it tries to save the parsed
version of the DTD in the xemacs directory structure (and of course, it doesn't
have the permissions). This happen every time you try to insert a tag.

I am starting to wonder whether I am the only person in the world trying to
write SGML documents with XEmacs under Red Hat 8^).

Note You need to log in before you can comment on or make changes to this bug.