Bug 218302 - Leaking file descriptor to /var/lib/rpm
Leaking file descriptor to /var/lib/rpm
Status: CLOSED DUPLICATE of bug 247601
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-04 10:38 EST by Daniel Walsh
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 01:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2006-12-04 10:38:14 EST
Description of problem:

I am seeing lots of avc's because of a leaked file descriptor.

avc: denied { read, write } for comm="rpc.idmapd" dev=dm-0 egid=0 euid=0
exe="/usr/sbin/rpc.idmapd" exit=0 fsgid=0 fsuid=0 gid=0 items=0 name="__db.000"
path="socket:[23823]" pid=8823 scontext=root:system_r:rpcd_t:s0 sgid=0
subj=root:system_r:rpcd_t:s0 suid=0 tclass=file
tcontext=root:object_r:rpm_var_lib_t:s0 tty=(none) uid=0
Version-Release number of selected component (if applicable):

rpm-4.4.2-36.el5
Comment 1 Paul Nasrat 2006-12-04 11:12:56 EST
What are the steps to reproduce? 
Comment 2 Daniel Walsh 2006-12-04 11:18:50 EST
I got this on a yum update.

Got the same avcs on depmod, mkinitrd, dmsetup, restorecond, semodule, groupadd
useradd ...

So it looks like stuff done in postinstalls is triggering it.  Happend on 12/2
yum update of RHEL5 Beta.
Comment 3 Paul Nasrat 2006-12-04 11:41:38 EST
Does it occur if you use rpm cli to upgrade the same packages?
Comment 4 Red Hat Bugzilla 2007-08-21 01:30:11 EDT
User pnasrat@redhat.com's account has been closed
Comment 5 Panu Matilainen 2007-08-22 02:35:12 EDT
Reassigning to owner after bugzilla made a mess, sorry about the noise...
Comment 6 Panu Matilainen 2007-09-04 01:41:09 EDT
Sounds a lot like dupe of 247601 - especially since we're talking about RHEL
here, not Fedora which this was filed against.

*** This bug has been marked as a duplicate of 247601 ***

Note You need to log in before you can comment on or make changes to this bug.