Bug 218316 - gstreamer-0.10.10-2 hangs after receiving ogg stream metadata
gstreamer-0.10.10-2 hangs after receiving ogg stream metadata
Status: CLOSED DUPLICATE of bug 216818
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-04 11:55 EST by Luis Cruz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 04:44:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Cruz 2006-12-04 11:55:12 EST
Description of problem:

Gstreamer hangs while playing an ogg stream from the Internet (see the exemple
below) after receiving new embedded metadata.

Version-Release number of selected component (if applicable):

Fedora Core 6
gstreamer-0.10.10-2.fc6
gstreamer-tools-0.10.10-2.fc6
gstreamer-plugins-good-0.10.4-1.fc6
gstreamer-plugins-base-0.10.10-1.fc6
rhythmbox-0.9.5-8.fc6
totem-2.16.3-1.fc6

How reproducible: Always


Steps to Reproduce:
1. gst-launch -t -v playbin uri="http://ogg2.smgradio.com/vc160.ogg"

  
Actual results:

gst-launch -t -v playbin uri="http://ogg2.smgradio.com/vc160.ogg"
Setting pipeline to PAUSED ...
/playbin0/source: iradio-genre = "Classic Rock"
/playbin0/source: iradio-name = "Virgin Radio Classic Rock"
Pipeline is PREROLLING ...
/playbin0/decoder/typefind.src: caps = application/ogg
/playbin0/decoder/oggdemux0.sink: caps = application/ogg
/playbin0/selector_audio_src0: active-pad = "sink0"
/playbin0/decoder/vorbisdec1.src: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
FOUND TAG      : found by element "vorbisdec1".
          artist: Virgin Radio Classic Rock
           title: The original classic rock station
         encoder: Xiph.Org libVorbis I 20030909
 encoder version: 0
     audio codec: Vorbis
 nominal bitrate: 160003
         bitrate: 160003
/playbin0/preroll_audio_src0: min-threshold-time = 2000000000
/playbin0/decoder/queue0.sink: caps = audio/x-vorbis
/playbin0/decoder/queue0.src: caps = audio/x-vorbis
/playbin0/decoder/vorbisdec1.sink: caps = audio/x-vorbis
/playbin0/selector_audio_src0.sink0: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/decoder.src0: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/decoder.src0.proxypad1: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/selector_audio_src0.src: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/preroll_audio_src0.sink: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/preroll_audio_src0: min-threshold-time = 0
/playbin0/preroll_audio_src0.src: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/abin/aconv.src: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/aconv.sink: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/abin.sink: caps = audio/x-raw-float, rate=(int)44100, channels=(int)2,
endianness=(int)1234, width=(int)32
/playbin0/abin.sink: caps = audio/x-raw-float, rate=(int)44100, channels=(int)2,
endianness=(int)1234, width=(int)32
/playbin0/abin.sink.proxypad3: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/abin/aresample.src: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/aresample.sink: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/volume.src: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/volume.sink: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/audiosink/audiosink-actual-sink-alsa.sink: caps =
audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)16,
depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/audiosink.sink: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/audiosink.sink: caps = audio/x-raw-int, endianness=(int)1234,
signed=(boolean)true, width=(int)16, depth=(int)16, rate=(int)44100, channels=(int)2
/playbin0/abin/audiosink.sink.proxypad2: caps = audio/x-raw-int,
endianness=(int)1234, signed=(boolean)true, width=(int)16, depth=(int)16,
rate=(int)44100, channels=(int)2
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: audioclock0
/playbin0/preroll_audio_src0: min-threshold-time = 2000000000
/playbin0/preroll_audio_src0: min-threshold-time = 0
/playbin0/decoder/vorbisdec1.src: caps = NULL
/playbin0/decoder/vorbisdec1.sink: caps = NULL
/playbin0/decoder/queue0.src: caps = NULL
/playbin0/decoder/queue0.sink: caps = NULL
/playbin0/decoder/queue2.sink: caps = audio/x-vorbis
/playbin0/decoder/vorbisdec3.src: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
FOUND TAG      : found by element "vorbisdec3".
          artist: Whitesnake
           title: Fool for your loving
         encoder: Xiph.Org libVorbis I 20030909
 encoder version: 0
     audio codec: Vorbis
 nominal bitrate: 160003
         bitrate: 160003
/playbin0/decoder/queue2.src: caps = audio/x-vorbis
/playbin0/decoder/vorbisdec3.sink: caps = audio/x-vorbis
/playbin0/selector_audio_src1.sink0: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/decoder.src1: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/decoder.src1.proxypad4: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/selector_audio_src1.src: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/preroll_audio_src1.sink: caps = audio/x-raw-float, rate=(int)44100,
channels=(int)2, endianness=(int)1234, width=(int)32
/playbin0/preroll_audio_src0: min-threshold-time = 2000000000


Expected results: N/A


Additional info:

Rhythmbox and Totem also hang as a consequence of this apparent bug.
Comment 1 Bastien Nocera 2007-02-02 04:44:11 EST
This is a dupe of bug 216818, where the stream gets out of sync when the
out-of-bounds title update gets through the stream.

*** This bug has been marked as a duplicate of 216818 ***

Note You need to log in before you can comment on or make changes to this bug.