Bug 218330 - NFS with Kereberos completely broken on 2.6.18 and 2.6.19
NFS with Kereberos completely broken on 2.6.18 and 2.6.19
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-04 13:34 EST by Paarvai Naai
Modified: 2014-06-18 03:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.20-ish kernels
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 16:44:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paarvai Naai 2006-12-04 13:34:33 EST
Description of problem:
---
NFS with Kerberos is completely broken since 2.6.18 due to a bug in the NFS
client code.  An NFS client can no longer mount more than one NFS+KRB5 volume
from a single server.  If you try to do so, you will get the error:

mount.nfs: File exists

from the mount program.


Version-Release number of selected component (if applicable):
---
Any kernel 2.6.18 and up.


How reproducible:
---
This is 100% reproducible.
---
Steps to Reproduce:
1. Export two share using either NFSv4 or NFSv3 with the sec=krb5 option.
2. Mount one on the client.
3. Try to mount the other on the client.


Actual results:
---
You will now see the "File exists" error.
  
Expected results:
---
The mount should complete without incident.


Additional info:
---
This is an urgent problem that needs attention.  The problem has been isolated.
 See the following mailing list post:

http://linux-nfs.org/pipermail/nfsv4/2006-November/005306.html

And a patch has been proposed:

http://linux-nfs.org/pipermail/nfsv4/2006-November/005315.html

The patch works on 2.6.19 vanilla kernel (it does not apply cleanly on 2.6.18
and a simple readjustment of the patch does not work) as verified by both the
maintainer and myself.

Here's what I suggest:  add the patch ASAP to the Fedora SRPM of kernel 2.6.19
and propagate this new kernel release to FC5 updates as well as FC6 updates.
Comment 1 Kostas Georgiou 2006-12-05 12:50:59 EST
This of course affects FC6. I suspect the beta of RHEL5 (although I can't check
at the moment) will have the same problem as well.
Comment 2 Paarvai Naai 2006-12-05 14:09:03 EST
Yes, that's why I listed that the kernel SRPM include the patch and be released
in FC5 and FC6.  That's also a good point about RHEL 5.  Can someone move this
forward soon?  Thanks!
Comment 3 Paarvai Naai 2006-12-07 14:33:28 EST
I haven't heard anything back from anyone about this bug.  I've been fighting
this problem for nearly two months and it's getting very frustrating, especially
since 2.6.17 has now been removed from the fc5 updates repository!!!  This has
caused considerable inconvenience for our company since we use NFSv3+Kerberos
and need to have machines installed with a properly working kernel.

I am unable to increase the urgency field past "Urgent", so can someone help me out.

Thanks.
Comment 4 Kostas Georgiou 2006-12-07 17:11:26 EST
Cloning the bug to FC6 and possibly RHEL5b2 might help there. It usually takes
some time before that bug is assigned to anyone but lack of activity in bugzilla
doesn't necessarily mean that someone isn't looking at it right now.
Comment 5 Jeff Layton 2008-01-24 16:44:24 EST
Sorry it's taken so long to get to this bug. It sounds like there was an
upstream fix to this problem in 2.6.20 or so? In any case, I believe this bug to
fixed at this point. Please reopen it if you're still experiencing this problem
with the most current kernel from F7 or later releases.

Note You need to log in before you can comment on or make changes to this bug.