Bug 218417 - 'PirutError' is not defined traceback
Summary: 'PirutError' is not defined traceback
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-05 07:31 UTC by Luke Macken
Modified: 2016-09-20 02:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 20:38:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luke Macken 2006-12-05 07:31:38 UTC
I'm getting the following traceback when trying to install a mugshot rpm using
pirut-1.2.8-1.fc6.

Component: Software Installer
Summary: TBbc65f3bf Progress.py:76:callback:NameError: global name 'PirutError'
is not defined

Traceback (most recent call last):
  File "/usr/sbin/system-install-packages", line 204, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 567, in
applyChanges
    self.runTransaction(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 542, in
runTransaction
    tserrors = yum.YumBase.runTransaction(self, tsprog)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 454, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.4/site-packages/pirut/Progress.py", line 76, in callback
    raise PirutError, "Unable to open %s: %s" %(rpmloc, e)
NameError: global name 'PirutError' is not defined

Local variables in innermost frame:
what: 4
e: [Errno 2] No such file or directory: '/tmp/mugshot-1.1.26-1.fc6.i386.rpm'
hdr: <rpm.hdr object at 0x91e02f0>
h: (<rpm.hdr object at 0x91e02f0>, '/tmp/mugshot-1.1.26-1.fc6.i386.rpm')
self: <pirut.Progress.PirutTransactionProgress instance at 0x941066c>
logmsg: 
rpmloc: /tmp/mugshot-1.1.26-1.fc6.i386.rpm
amount: 0
user: 
total: 0
PREP: 0.25

Comment 1 Jeremy Katz 2006-12-06 16:05:10 UTC
Fixed the traceback in CVS, but you're still going to be having a problem -- is
the rpm not actually there?

Comment 2 Luke Macken 2006-12-06 16:39:40 UTC
I think the problem was that I closed Firefox right when the download was
complete, which probably pulled the rpm out from underneath of it.


Note You need to log in before you can comment on or make changes to this bug.