Bug 218443 - Wrong format of date in the login screen (cs_CZ locale)
Wrong format of date in the login screen (cs_CZ locale)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 07:03 EST by Jan "Yenya" Kasprzak
Modified: 2009-03-11 05:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:42:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2006-12-05 07:03:22 EST
Description of problem:
The date and time in the gdm login screen is incorrectly formated with the Czech
locale (cs_CZ.UTF-8)

Version-Release number of selected component (if applicable):
gdm-2.16.0-18.fc6

Steps to Reproduce:
1. set "LANG=cs_CZ.UTF-8" in /etc/sysconfig/i18n
2. restart gdm
3. look at the date printed in the bottom right corner

Actual results:
Út 05 pro 2006, ...

Expected results:
Út 5. prosinec 2006, ...


Additional info:
In the Czech language, we almost never use abbreviations of the month names (it
is defined in the locale, but it is almost never used in real life). We also do
not use leading zeros in the month or day numbers. I think gdm should use the
"%c" format string of strftime(3), so that it prints the date and time as
preferred by the current locale. On my system, date +%c prints the following:

$ LC_ALL=cs_CZ.UTF-8 date +%c
Út  5. prosinec 2006, 12:58:37 CET

which is the right way of print the date + time in the Czech locale.
Comment 1 Mike A. Harris 2007-11-09 08:32:54 EST
If you switch to runlevel 3, and use "startx", then open a terminal and type
"locale", do the settings you expect show up?  Does the default GNOME clock show
the date correctly?

This is probably caused by bug #372151
Comment 2 Ray Strode [halfline] 2008-03-18 14:42:09 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)
Comment 3 Jan "Yenya" Kasprzak 2008-03-21 16:01:03 EDT
I have installed current rawhide in a virtual machine, and the date in the Czech
locale seems to be correct. So apparently the problem has been fixed upstream.
Comment 4 Mike A. Harris 2009-03-11 05:16:16 EDT
The problem was allegedly fixed and released as erratum for Fedora 8 and above a while back.  It's commented about in bug #372151 which I refered to above.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.