Bug 218455 - ocaml + swig produces bad code
Summary: ocaml + swig produces bad code
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-05 14:31 UTC by John Ellson
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-22 16:58:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2006-12-05 14:31:22 UTC
Description of problem:
Recent ocaml-3.09.3-1.fc5 update results in bad C++ code being generated by swig.
 
ocaml-3.09.2-1.fc5 + swig-1.3.24-2.2.1 is OK.

Version-Release number of selected component (if applicable):
ocaml-3.09.3-1.fc5
swig-1.3.24-2.2.1

How reproducible:
100%


Steps to Reproduce:
1. compile graphviz-2.12 (upstream release from www.graphviz.org) on fully
updated fc5
2.
3.
  
Actual results:
gv_ocaml.cpp: In function 'double caml_double_val(caml_value_t)':
gv_ocaml.cpp:1092: warning: converting to 'caml_value_t' from 'double'
gv_ocaml.cpp: In function 'void* caml_ptr_val(caml_value_t, swig_type_info*)':
gv_ocaml.cpp:1148: error: invalid conversion from 'void*' to 'caml_value_t'
gv_ocaml.cpp:1148: error: invalid conversion from 'caml_value_t' to 'void*'
gv_ocaml.cpp: In function 'caml_value_t _wrap_graph__SWIG_0gv(caml_value_t)':
gv_ocaml.cpp:1581: error: 'value' was not declared in this scope
gv_ocaml.cpp:1581: error: expected `;' before 'caml__temp_result'
gv_ocaml.cpp:1581: error: 'caml__temp_result' was not declared in this scope
...

Expected results:


Additional info:

Comment 1 Gérard Milmeister 2006-12-05 15:10:42 UTC
Does it work with the newest version of swig? If yes, you might request an
update for swig. Otherwise, does it work with upstream ocaml? If yes, then there
might be a problem with packaging. In any other case, I fear the problem lies
with upstream ocaml, and you have to report it to them.

Comment 2 John Ellson 2006-12-05 16:30:58 UTC
ocaml-3.09.3-1.fc7 + swig-1.3.31-0.fc7 on Fedora Rawhide is OK.

ocaml-3.09.3-1.fc7 + swig-1.3.31-0.fc5 (built from fc7 src.rpm) on FC5 is OK

Sounds like swig should be updated on FC5.   I'll generate a bug against swig.

Comment 3 Gérard Milmeister 2006-12-05 18:33:21 UTC
(In reply to comment #2)
> Sounds like swig should be updated on FC5.
> I'll generate a bug against swig.
Good, so the problem is found.
However, I fear that the update won't happen :-(

Comment 5 Gérard Milmeister 2007-02-22 16:58:20 UTC
swig is now 1.3.31 in fc5


Note You need to log in before you can comment on or make changes to this bug.