Bug 218458 - eclipse hangs in workspace launcher after yum update
eclipse hangs in workspace launcher after yum update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 10:13 EST by Thomas Diesler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2.1-23.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-01 10:23:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Diesler 2006-12-05 10:13:45 EST
Description of problem:

The gtk file-chooser hangs in various eclipse dialogs (i.e. Browse button in the
Workspace Launcher, Add Jars in User Libraries)

This happens on my FC6 workstaion in the office and my home laptop.
Here is the stacktrace

"main" prio=1 tid=0x0813ab58 nid=0x34a4 runnable [0xbf8a2000..0xbf8a3388]
        at org.eclipse.swt.internal.gtk.OS._gtk_file_chooser_dialog_new(Native
Method)
        at org.eclipse.swt.internal.gtk.OS.gtk_file_chooser_dialog_new(OS.java:4400)
        at
org.eclipse.swt.widgets.DirectoryDialog.openChooserDialog(DirectoryDialog.java:124)
        at org.eclipse.swt.widgets.DirectoryDialog.open(DirectoryDialog.java:116)
        at
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog$2.widgetSelected(ChooseWorkspaceDialog.java:239)
        at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:90)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
        at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3166)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2842)
        at org.eclipse.jface.window.Window.runEventLoop(Window.java:820)
        at org.eclipse.jface.window.Window.open(Window.java:796)
        at
org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(ChooseWorkspaceDialog.java:89)
        at
org.eclipse.ui.internal.ide.IDEApplication.promptForWorkspace(IDEApplication.java:243)
        at
org.eclipse.ui.internal.ide.IDEApplication.checkInstanceLocation(IDEApplication.java:190)
        at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:81)
        at
org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
        at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
        at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
        at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
        at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
        at org.eclipse.core.launcher.Main.run(Main.java:977)
        at org.eclipse.core.launcher.Main.main(Main.java:952)

Here are gtk2 relevant packages.

[tdiesler@localhost ~]$ yum list installed | grep gtk2
gtk2.i386                                2.10.4-6.fc6           installed       
gtk2-engines.i386                        2.8.0-1.fc6            installed       
libswt3-gtk2.i386                        1:3.2.1-4.fc6          installed       
pygtk2.i386                              2.10.3-2.fc6           installed       
pygtk2-libglade.i386                     2.10.3-2.fc6           installed  

I tried eclipse 3.2.1 and 3.3M3. Even after downgrading to gtk2-2.10.4-4 the
symptom still occurs.

[tdiesler@localhost ~]$ java -version
java version "1.5.0_09"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_09-b03)
Java HotSpot(TM) Client VM (build 1.5.0_09-b03, mixed mode, sharing)

Other packages that where updated since the last working version are:

Nov 24 01:33:39 Updated: gtk2.i386 2.10.4-5.fc6
Nov 24 01:33:40 Updated: nspr.i386 4.6.4-0.6.fc6
Nov 24 01:33:41 Updated: nss.i386 3.11.4-0.6.fc6
Nov 24 01:33:42 Updated: gstreamer-tools.i386 0.10.10-2.fc6
Nov 24 01:33:48 Updated: util-linux.i386 2.13-0.45.1.fc6
Nov 24 01:34:21 Updated: gnome-panel.i386 2.16.1-3.fc6
Nov 24 01:34:30 Updated: ImageMagick.i386 6.2.8.0-3.fc6.1
Nov 24 01:34:30 Installed: cyrus-sasl-md5.i386 2.1.22-4
Nov 24 01:34:32 Updated: vnc-server.i386 4.1.2-6.fc6
Nov 24 01:34:34 Updated: nss-tools.i386 3.11.4-0.6.fc6
Nov 24 01:34:36 Updated: gstreamer.i386 0.10.10-2.fc6
Nov 24 01:34:39 Updated: gstreamer-plugins-base.i386 0.10.10-1.fc6
Nov 24 01:35:19 Updated: totem.i386 2.16.3-1.fc6
Nov 24 01:35:30 Updated: gaim.i386 2.0.0-0.22.beta5.fc6
Nov 24 01:35:30 Updated: totem-mozplugin.i386 2.16.3-1.fc6
Nov 24 01:35:44 Updated: rhythmbox.i386 0.9.5-7.fc6
Nov 27 08:05:19 Installed: kmobiletools.i386 0.4.3.3-3.fc6
Dec 03 15:19:52 Updated: audit-libs.i386 1.3-2.fc6
Dec 03 15:19:56 Updated: dbus.i386 1.0.1-2.fc6
Dec 03 15:19:59 Updated: dbus-glib.i386 0.70-5.fc6
Dec 03 15:20:07 Updated: hal.i386 0.5.8.1-5.fc6
Dec 03 15:20:10 Updated: cups-libs.i386 1:1.2.7-1.3.fc6
Dec 03 15:20:16 Updated: openssl.i686 0.9.8b-8.3.fc6
Dec 03 15:20:22 Updated: freetype.i386 2.2.1-15.fc6
Dec 03 15:20:26 Updated: pango.i386 1.14.8-1.fc6
Dec 03 15:20:40 Updated: evolution-data-server.i386 1.8.1-2.fc6
Dec 03 15:20:43 Updated: dbus-x11.i386 1.0.1-2.fc6
Dec 03 15:20:45 Updated: audit-libs-python.i386 1.3-2.fc6
Dec 03 15:20:51 Updated: policycoreutils.i386 1.33.2-2.fc6
Dec 03 15:20:54 Updated: pygobject2.i386 2.12.3-1.fc6
Dec 03 15:21:03 Updated: redhat-menus.noarch 6.7.8-2.fc6
Dec 03 15:21:42 Updated: control-center.i386 1:2.16.0-11.fc6
Dec 03 15:22:07 Updated: gnome-volume-manager.i386 2.15.0-4.fc6
Dec 03 15:22:17 Updated: selinux-policy.noarch 2.4.5-3.fc6
Dec 03 15:22:30 Updated: gnome-pilot.i386 2.0.14-1.fc6
Dec 03 15:22:43 Updated: planner.i386 0.14.2-1.fc6
Dec 03 15:22:51 Updated: spamassassin.i386 3.1.7-1.fc6
Dec 03 15:22:53 Updated: net-snmp-libs.i386 1:5.3.1-12.fc6
Dec 03 15:22:57 Updated: system-config-printer-libs.i386 0.7.40-1.fc6
Dec 03 15:22:59 Updated: SDL.i386 1.2.10-8.fc6
Dec 03 15:23:02 Updated: authconfig.i386 5.3.12-1.fc6
Dec 03 15:23:05 Updated: gmp.i386 4.1.4-9.fc6
Dec 03 15:23:21 Updated: gnome-power-manager.i386 2.16.0-4.fc6
Dec 03 15:23:33 Updated: gjdoc.i386 0.7.7-14.fc6
Dec 03 15:23:50 Updated: gnome-session.i386 2.16.0-7.fc6
Dec 03 15:24:12 Updated: cups.i386 1:1.2.7-1.3.fc6
Dec 03 15:24:17 Updated: parted.i386 1.8.0-1.fc6
Dec 03 15:24:22 Updated: system-config-soundcard.noarch 2.0.5-2.fc6
Dec 03 15:24:27 Updated: ppp.i386 2.4.4-1.fc6
Dec 03 15:24:31 Updated: system-config-printer.i386 0.7.40-1.fc6
Dec 03 15:24:49 Updated: rhythmbox.i386 0.9.5-8.fc6
Dec 03 15:24:54 Updated: nfs-utils.i386 1:1.0.10-4.fc6
Dec 03 15:24:57 Updated: mlocate.i386 0.15-0.fc6.1
Dec 03 15:25:01 Updated: vnc-server.i386 4.1.2-7.fc6
Dec 03 15:25:03 Updated: traceroute.i386 3:2.0.2-1.fc6
Dec 03 15:25:05 Updated: authconfig-gtk.i386 5.3.12-1.fc6
Dec 03 15:25:25 Updated: tzdata.noarch 2006p-1.fc6
Dec 03 15:26:05 Updated: hsqldb.i386 1:1.8.0.4-4jpp.1
Dec 03 15:26:24 Updated: selinux-policy-targeted.noarch 2.4.5-3.fc6
Dec 03 15:29:05 Updated: dkms-ipw3945.noarch 1.1.2-1
Dec 04 22:31:56 Installed: yum-allowdowngrade.noarch 1.0.1-1.fc6
Dec 04 22:51:01 Updated: gtk2.i386 2.10.6-6.fc7
Dec 04 22:57:52 Updated: gtk2.i386 2.10.4-6.fc6
Dec 04 22:57:53 Updated: libsoup.i386 2.2.98-1.fc6
Dec 04 22:58:04 Updated: evolution-data-server.i386 1.8.2-1.fc6
Dec 04 22:58:20 Updated: gnome-icon-theme.noarch 2.16.0.1-3.fc6
Dec 04 22:58:24 Updated: gtkhtml3.i386 3.12.2-1.fc6
Dec 04 22:58:24 Updated: libsepol.i386 1.15.3-1.fc6
Dec 04 22:58:29 Updated: policycoreutils.i386 1.33.5-4.fc6
Dec 04 22:58:35 Updated: selinux-policy.noarch 2.4.6-1.fc6
Dec 04 22:59:26 Updated: evolution.i386 2.8.2.1-2.fc6
Dec 04 22:59:27 Updated: gamin.i386 0.1.7-8.fc6
Dec 04 22:59:28 Updated: ypbind.i386 3:1.19-6.fc6
Dec 04 22:59:32 Updated: autofs.i386 1:5.0.1-0.rc2.25
Dec 04 22:59:46 Updated: selinux-policy-targeted.noarch 2.4.6-1.fc6
Dec 04 22:59:47 Updated: paps.i386 0.6.6-17.fc6
Dec 04 23:26:26 Updated: gtk2.i386 2.10.4-5.fc6
Dec 05 11:51:19 Updated: freetype.i386 2.2.1-16.fc6
Dec 05 11:51:33 Updated: gtk2.i386 2.10.4-6.fc6
Dec 05 11:51:35 Updated: tar.i386 1.15.1-22.fc6
Dec 05 11:56:32 Installed: strace.i386 4.5.14-3
Comment 1 Andrew Overholt 2006-12-05 10:16:28 EST
Could this be a duplicate of bug #217843?
Comment 2 Thomas Diesler 2006-12-05 10:32:30 EST
This has also been filed here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=166788
Comment 3 Thomas Diesler 2006-12-05 11:13:43 EST
Yes, it seems top be a policy issue

This fixed it fo me

[root@localhost ~]# rpm -e --nodeps selinux-policy selinux-policy-targeted

[root@localhost ~]# yum install selinux-policy selinux-policy-targeted
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for selinux-policy-targeted to pack into transaction set.
selinux-policy-targeted-2 100% |=========================|  34 kB    00:00     
---> Package selinux-policy-targeted.noarch 0:2.4.6-1.fc6 set to be updated
---> Downloading header for selinux-policy to pack into transaction set.
selinux-policy-2.4.6-1.fc 100% |=========================|  59 kB    00:00     
---> Package selinux-policy.noarch 0:2.4.6-1.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 selinux-policy          noarch     2.4.6-1.fc6      updates           339 k
 selinux-policy-targeted  noarch     2.4.6-1.fc6      updates           747 k

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.1 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): selinux-policy-tar 100% |=========================| 747 kB    00:01     
(2/2): selinux-policy-2.4 100% |=========================| 339 kB    00:00     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: selinux-policy               ######################### [1/2] 
  Installing: selinux-policy-targeted      ######################### [2/2] 
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different
specifications for /var/run/pcscd\.pub  (system_u:object_r:pcscd_var_run_t:s0
and system_u:object_r:initrc_var_run_t:s0).
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different
specifications for /var/run/pcscd\.pid  (system_u:object_r:pcscd_var_run_t:s0
and system_u:object_r:initrc_var_run_t:s0).

Installed: selinux-policy.noarch 0:2.4.6-1.fc6 selinux-policy-targeted.noarch
0:2.4.6-1.fc6
Complete!
Comment 4 Thomas Diesler 2006-12-05 11:16:39 EST
Note however, that this installes the same policy packages as I had before. ???
Comment 5 Andrew Overholt 2006-12-05 11:17:39 EST
At [1], Dan Walsh says this is fixed in selinux-policy-2.4.6-6.

Can you close the upstream bug?

[1]
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217843#c27
Comment 6 Ben Konrath 2007-01-31 18:13:12 EST
Thomas, is Eclipse working for you now? Can we close this bug?
Comment 7 Thomas Diesler 2007-02-01 03:49:57 EST
Yes, this can be closed

Note You need to log in before you can comment on or make changes to this bug.