Bug 218496 - scsi0:A:6:0: DV failed to configure device.
scsi0:A:6:0: DV failed to configure device.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 14:01 EST by Joe Smith
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 13:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Smith 2006-12-05 14:01:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
Description of problem:

We are running an application that uses Oracle & we use Oracle Secure Backup to backup to a Dell PowerVault 110T DLT VS160 tape drive.  That backup is scheduled to start at 00:00 (midnight).  When this error occurs, the lights on the Dell PowerVault DLT tape drive settle on:  Ready light not lit, Fault light solid amber, Clean light solid amber, Media light not lit.  The tape drive is unresponsive (i.e. won't eject tape or reset itself), & the server must be rebooted in order to get the tape drive to respond.

At first we suspected a bad tape, but then the error occurred with a known good tape.  Next, we called Dell.  They replaced the tape drive & SCSI cable on 11/30/06.  It worked fine until today, 12/5/06.

/var/log/messages has these entries

Dec  5 00:38:23 penta01 kernel: (scsi0:A:6:0): Unexpected busfree in Command phase
Dec  5 00:38:23 penta01 kernel: SEQADDR == 0x172
Dec  5 00:39:42 penta01 kernel: scsi0:A:6:0: DV failed to configure device.  Please file a bug report against this driver.
Dec  5 00:39:42 penta01 kernel: (scsi0:A:6): 3.300MB/s transfers
Dec  5 04:02:02 penta01 nmbd[3343]: [2006/12/05 04:02:02, 0] nmbd/nmbd.c:process(542) 
Dec  5 04:02:02 penta01 nmbd[3343]:   Got SIGHUP dumping debug info. 
Dec  5 04:02:02 penta01 nmbd[3343]: [2006/12/05 04:02:02, 0] nmbd/nmbd_workgroupdb.c:dump_workgroups(284) 
Dec  5 04:02:02 penta01 nmbd[3343]:   dump_workgroups() 
Dec  5 04:02:02 penta01 nmbd[3343]:    dump workgroup on subnet       10.0.0.15: netmask=  255.255.255.0: 
Dec  5 04:02:02 penta01 nmbd[3343]:   	EEAUSTIN(1) current master browser = NETSERVER 
Dec  5 04:02:02 penta01 nmbd[3343]:   		PENTA01 40019b03 (PENTA01) 
Dec  5 04:02:02 penta01 nmbd[3343]:   		NETSERVER 4006160f () 
Dec  5 04:02:02 penta01 nmbd[3343]: [2006/12/05 04:02:02, 0] nmbd/nmbd_workgroupdb.c:dump_workgroups(284) 
Dec  5 04:02:02 penta01 nmbd[3343]:   dump_workgroups() 
Dec  5 04:02:02 penta01 nmbd[3343]:    dump workgroup on subnet  UNICAST_SUBNET: netmask=      10.0.0.15: 
Dec  5 04:02:02 penta01 nmbd[3343]:   	EEAUSTIN(1) current master browser = UNKNOWN 
Dec  5 04:02:02 penta01 nmbd[3343]:   		PENTA01 40019b03 (PENTA01) 


Previously, I've gotten a similar entry after rebooting.  That entry was as follows:
Nov 13 11:47:29 penta01 kernel: scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
Nov 13 11:47:29 penta01 kernel:         <Adaptec 3960D Ultra160 SCSI adapter>
Nov 13 11:47:29 penta01 kernel:         aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCB's
Nov 13 11:47:29 penta01 kernel:
Nov 13 11:47:29 penta01 kernel: scsi0:A:6:0: DV failed to configure device.  Please file a bug report against this driver.
Nov 13 11:47:29 penta01 kernel: (scsi0:A:6): 160.000MB/s transfers (80.000MHz DT, offset 96, 16bit)
Nov 13 11:47:29 penta01 kernel:   Vendor: QUANTUM   Model: DLT VS160         Rev: 2C00
Nov 13 11:47:29 penta01 kernel:   Type:   Sequential-Access                  ANSI SCSI revision: 02
Nov 13 11:47:29 penta01 kernel: scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
Nov 13 11:47:29 penta01 kernel:         <Adaptec 3960D Ultra160 SCSI adapter>
Nov 13 11:47:29 penta01 kernel:         aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCB's

How reproducible:
Happens about once per week when the Oracle backup starts to run.  Occasionally will get the "DV failed to configure this device" message on a reboot.


Version-Release number of selected component (if applicable):
kernel-2.6.9-42.0.3.EL

How reproducible:
Sometimes


Steps to Reproduce:
1. Reboot
2. or wait 4 or 5 days for the error reoccur when backing up.


Actual Results:
Tape Drive stops responding, server must be rebooted to get tape out of drive.

Expected Results:
Backup performs once daily, able to eject tape, tape drive functions normally.

Additional info:
Server is a Dell PowerEdge 1800.
It's possible that this is an issue w/ the driver supplied w/ the tape drive, but I'm not sure.
Comment 1 Chip Coldwell 2007-09-05 17:31:35 EDT
(In reply to comment #0)
> 
> Dec  5 00:39:42 penta01 kernel: scsi0:A:6:0: DV failed to configure device. 
Please file a bug report against this driver.

Which SCSI driver is this?  (e.g. aic79xx, mptscsih, sym53c8xx)?

Chip
Comment 2 Joe Smith 2007-10-12 13:07:39 EDT
(In reply to comment #1)
 
> Which SCSI driver is this?  (e.g. aic79xx, mptscsih, sym53c8xx)?
> 
> Chip
> 

The SCSI driver is aic78xx.
Thank you for your time.  However, I believe the problem was resolved.  Dell
installed a new DLT tape drive, SCSI cable, and SCSI controller.
The new drive has been working well over the last month.

It seems to have been a faulty piece of hardware, not a driver issue.
Thanks.

Joe

Note You need to log in before you can comment on or make changes to this bug.