Bug 218522 - HTS: Multiple Documentation Bugs
HTS: Multiple Documentation Bugs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Greg Nichols
http://www.hp.com
:
: 223473 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-05 15:31 EST by Chris Moore
Modified: 2008-07-16 17:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-06 08:42:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Moore 2006-12-05 15:31:43 EST
Description of problem:  

1. (Usage Guide) Expand: on the SUT setup—which packages to install and what
partition structure to use for the RHEL5 installation and which HTS rpms to
install. 

2. (Usage Guide) Incorrect: “hts print –report plan” gives an error—simply “hts
print” is the correct wording. 

3. (Usage Guide and Command Reference) Expand: on the –udi={hal_hadware_address}
switch. Where would the addresses be found? 

4. (Usage Guide) Clarify: Under “virtualization” does “NFS server” refer to the
SUT or the Test Server? 

5. (Usage Guide) Expand: please expand all the test descriptions to include what
sub-processes are running in each test. Possibly include time estimates for each
test, too.
 
6. (Usage Guide) Add info: For the virtualization test description where are the
files (the xen config file(/etc/xen/RHEL51-virt1) and the os image
file(/tmp/virt/virt1.img)) placed. Also, add information on how to run the test
the test properly with paravirtualization. 




Version-Release number of selected component (if applicable):
HTS documentation
Comment 1 Irina Boverman 2007-01-11 11:08:40 EST
7. Need to indicate that virt test is only required for systems that have
hardware support for fully virtualized implementation, and it is enabled through
bias and firmware (Release Notes).
Comment 2 Greg Nichols 2007-01-11 16:32:52 EST
(In reply to comment #0)

Fixed/changed the following in Documentation for R16:

> Description of problem:  
> 
> 1. (Usage Guide) Expand: on the SUT setup—which packages to install and what
> partition structure to use for the RHEL5 installation and which HTS rpms to
> install. 

Reoganized and clarified Sections.

> 2. (Usage Guide) Incorrect: “hts print –report plan” gives an error—simply “hts
> print” is the correct wording. 
> 

hts print --report plan is correct usage to print the test plan.

> 3. (Usage Guide and Command Reference) Expand: on the –udi={hal_hadware_address}
> switch. Where would the addresses be found? 

Added information to this paragraph.

> 
> 4. (Usage Guide) Clarify: Under “virtualization” does “NFS server” refer to the
> SUT or the Test Server? 
SUT - clarified in doc.
> 
> 5. (Usage Guide) Expand: please expand all the test descriptions to include what
> sub-processes are running in each test. Possibly include time estimates for each
> test, too.

This is an overview only - left it as is.

>  
> 6. (Usage Guide) Add info: For the virtualization test description where are the
> files (the xen config file(/etc/xen/RHEL51-virt1) and the os image
> file(/tmp/virt/virt1.img)) placed. Also, add information on how to run the test
> the test properly with paravirtualization. 

The virtualization test is only run on systems where full-virtualization is 
supported. Clarified the document.

> Version-Release number of selected component (if applicable):
> HTS documentation

Comment 3 Chris Moore 2007-01-18 12:18:16 EST
There needs to be an instruction to add the mt-st package as that is now a
required dependency to install the hts rpm.
Comment 4 Greg Nichols 2007-01-18 16:57:53 EST
Changing state to Assigned, via above comments, plus the following:

For Virtualization Testing, the docs should address the following questions:

1. What is the guide line for creating FV guest?
2. Where is the manual/instruction to setup/create FV guest?
3. What is/are the minimum requirement(s) to perform virtualization test?
4. Instruction to create results.rpm ???
Comment 5 Greg Nichols 2007-01-19 19:52:06 EST
*** Bug 223473 has been marked as a duplicate of this bug. ***
Comment 6 Greg Nichols 2007-01-23 11:22:55 EST
(In reply to comment #4)

> For Virtualization Testing, the docs should address the following questions:
> 

Fixed R18.

(In reply to comment #3)
> There needs to be an instruction to add the mt-st package as that is now a
> required dependency to install the hts rpm.

HTS will only document packages needed in addition to RHEL

Comment 7 Danny Trinh 2007-01-24 10:32:28 EST
Can RH provide HTS R18 for us to verify?
1. If not, why?
2. If yes, when? where?

Note You need to log in before you can comment on or make changes to this bug.