Bug 218601 - RHEL5-B2: rmmod of network driver does not unload the driver
RHEL5-B2: rmmod of network driver does not unload the driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
: Reopened
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-12-06 08:03 EST by Raghavendra Biligiri
Modified: 2009-06-19 06:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 21:05:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (16.85 KB, application/x-gzip)
2006-12-06 08:05 EST, Raghavendra Biligiri
no flags Details

  None (edit)
Description Raghavendra Biligiri 2006-12-06 08:03:03 EST
Description of problem:
Installed RHEL5-B2 64-bit(kernel-2.6.18-1.2747.el5) on PE1800 which has Intel 
LOM.
When we stop the network service and try to unload the e1000 module,the module 
is not unloaded and it is still seen in the lsmod output.This issue is seen 
even with tg3 driver.
When we try to unload the e1000 module,we get the below message on the console :
PCI: Enabling device 0000:03:07.0 (0110 -> 0113)

Version-Release number of selected component (if applicable):
RHEL5-B2 64-bit(kernel-2.6.18-1.2747.el5)

How reproducible:


Steps to Reproduce:
1.Install RHEL5-B2 64-bit(kernel-2.6.18-1.2747.el5)
2.Stop the network service
3.Unload the network driver 
  
Actual results:
Network module does not get unloaded and still shows up in lsmod output.

Expected results:
Network module should get unloaded.

Additional info:
Attached the /var/log/messages
Comment 1 Raghavendra Biligiri 2006-12-06 08:05:42 EST
Created attachment 142949 [details]
/var/log/messages
Comment 2 Samuel Benjamin 2006-12-13 13:53:36 EST
Networking issue. Adding to 5.0 wish list to obtain ACKS.
Comment 3 RHEL Product and Program Management 2006-12-13 14:21:24 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Samuel Benjamin 2006-12-14 14:02:34 EST
Dell wants to confirm with RH network engineering if this is a known issue or
working as designed. Is there is any way to work around it then they will like
to know it.

Comment 5 Larry Troan 2007-01-03 14:33:49 EST
Per Engineering, this was a bug in initscripts where depending on whether
SELinux was active or not, a module could be reinserted after being removed via
rmmod. 

Reference bug 211474 'setenforce 0' will cause the modules to be re-loaded
automatically after remove by 'rmmod' which was fixed in
initscripts-8.45.10.EL-1.1. Fix was confirmed by another partner on 2006-12-11
and bug 211474 was CLOSED=CURRENTRELEASE.

*** This bug has been marked as a duplicate of 211474 ***
Comment 6 Amit Bhutani 2007-01-10 13:00:00 EST
Since we do not have access to bug 211474, we would have to test this ourselves
before we deem this fixed. 

Bili- Would you like to quickly regress and report results here ??
Comment 7 John A. Hull 2007-01-10 15:09:56 EST
I confirmed that this is resolved in RC snapshot 5. 

Note You need to log in before you can comment on or make changes to this bug.