Bug 218604 - evolution crash when open a particular html message
evolution crash when open a particular html message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 08:35 EST by Dario Lesca
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-06 19:15:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file generate with evolution --disable-eplugin --debug (551 bytes, text/plain)
2006-12-06 08:35 EST, Dario Lesca
no flags Details
Bug Buddy details (19.11 KB, text/plain)
2006-12-06 08:37 EST, Dario Lesca
no flags Details
Message witch cause the crash (26.91 KB, text/plain)
2007-01-15 07:32 EST, Dario Lesca
no flags Details
evolution strace log on a fc6 that crash evolution when open the message (985.41 KB, text/plain)
2007-01-15 07:32 EST, Dario Lesca
no flags Details
evolution strace log on a fc6 that NOT crash when open the message (1.49 MB, text/plain)
2007-01-15 07:37 EST, Dario Lesca
no flags Details

  None (edit)
Description Dario Lesca 2006-12-06 08:35:13 EST
Description of problem:

evolution crash when it's open a particoular html file 

Version-Release number of selected component (if applicable):
(see attach evo-bug-buddy.txt)

How reproducible:

In my case, open the follow html message crash evolution:
(see attach evo-debug.txt)

Steps to Reproduce:
1. open evolution
2. click on html message
3. evolution crash
  
Actual results:

evolution crash

Expected results:

not crash and open the message

Additional info:

If I run evolution whit --disable-eplugin option set the message is show and the
apps not crash
Comment 1 Dario Lesca 2006-12-06 08:35:14 EST
Created attachment 142950 [details]
file generate with evolution --disable-eplugin --debug
Comment 2 Dario Lesca 2006-12-06 08:37:48 EST
Created attachment 142951 [details]
Bug Buddy details
Comment 3 Lubomir Kundrak 2007-01-11 09:06:43 EST
(In reply to comment #0)
> In my case, open the follow html message crash evolution:
> (see attach evo-debug.txt)

Dario,

could you please provide an example reproducer?
In case the content of the message is private, could you please for
example replace the text with some random characters, or something
similar?

Thanks in advance
Comment 6 Lubomir Kundrak 2007-01-11 10:59:16 EST
> Excluding:  d.lesca@solinos.it
I am removing private flag from comment #3 and forward the mail to him.
Comment 7 Dario Lesca 2007-01-15 07:32:09 EST
Created attachment 145567 [details]
Message witch cause the crash

This is the message witch when open crash outlook
Comment 8 Dario Lesca 2007-01-15 07:32:54 EST
Created attachment 145568 [details]
evolution strace log on a fc6 that crash evolution when open the message
Comment 9 Dario Lesca 2007-01-15 07:37:00 EST
Created attachment 145569 [details]
evolution strace log on a fc6 that NOT crash when open the message

Strace run on fc6 system with some .evolution archive.
On this system evolution open the message and NOT crash
Comment 10 Dario Lesca 2007-01-15 07:42:29 EST
Comment on attachment 145568 [details]
evolution strace log on a fc6 that crash evolution when open the message

I have run strace -f -p # on a fc6 system before open the message that crash
evolution.
the system is fresh install and the homedir (with .evolution archive) is copy
from fc5
Comment 11 Dario Lesca 2007-01-15 07:46:38 EST
Comment on attachment 145569 [details]
evolution strace log on a fc6 that NOT crash when open the message

On this fresh instal system I have only copy the .evolution on my home and
evolution not crash .
Comment 12 Dario Lesca 2007-01-15 07:49:21 EST
On system that crash, if I open evolution with evolution --disable-eplugin --debug
the messagge is opened and evolution NOT crash.
Comment 13 Matthew Barnes 2007-10-06 19:15:51 EDT
Tested the message in comment #7 with Evolution 2.12.0 and it seems to render
properly.  I get red crosses where it looks like there should have been images.

Closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.