Bug 218617 - rhn-setup not installed, post upgrade from RHEL 4 -> RHEL 5 beta 2
rhn-setup not installed, post upgrade from RHEL 4 -> RHEL 5 beta 2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Bryan Kearney
Corey Welton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 10:01 EST by Clifford Perry
Modified: 2013-01-10 04:04 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-12 15:45:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2006-12-06 10:01:38 EST
Description of problem:
I performed an upgrade from the RHEL 4 Desktop to RHEL 5 beta 2 Client. 

Beyond the fact of a general failure of the upgrade process, the end result was,
that due to missing requires the 'rhn-setup' package did not get installed. It
seems quite important that if someone has the rhn-yum-plugin installed, that it
also pulls in and has all the other needed rhn-* packages. 

Post upgrade, I had the following not installed, only rhn-setup seems critical
to function:

rhn-setup-gnome
rhnsd
rhn-setup
rhn-check

I have not verified, but assume that rhn-check may also need to have a requires
by the yum-rhn-plugin. 

Version-Release number of selected component (if applicable):
[root@cperry network-scripts]# rpm -qa --last | grep rhn
rhn-setup-gnome-0.3.1-3.el5                   Sat 25 Nov 2006 09:50:01 PM EST
rhn-setup-0.3.1-3.el5                         Sat 25 Nov 2006 09:49:59 PM EST
rhnsd-4.5.1-1.el5                             Sat 25 Nov 2006 09:49:59 PM EST
rhn-check-0.3.1-3.el5                         Sat 25 Nov 2006 09:49:58 PM EST
yum-rhn-plugin-0.2.0-2.el5                    Thu 23 Nov 2006 05:12:49 PM EST
rhn-client-tools-0.3.1-3.el5                  Thu 23 Nov 2006 05:12:13 PM EST
rhnlib-2.2.5-1.el5                            Thu 23 Nov 2006 05:00:26 PM EST


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Critical rhn components were missing post upgrade

Expected results:
rhn_register to just work, post upgrade. 

Additional info:
[root@cperry ~]# rpm -q --obsoletes yum-rhn-plugin
up2date  
[root@cperry ~]# 

[root@cperry NotBackedUp]# find . | grep -i rhn| grep rpm
./1/Client/rhn-check-0.3.1-3.el5.noarch.rpm
./1/Client/rhn-client-tools-0.3.1-3.el5.noarch.rpm
./1/Client/rhn-setup-0.3.1-3.el5.noarch.rpm
./1/Client/rhnlib-2.2.5-1.el5.noarch.rpm
./1/Client/rhnsd-4.5.1-1.el5.i386.rpm
./1/Client/yum-rhn-plugin-0.2.0-2.el5.noarch.rpm
./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm
[root@cperry NotBackedUp]# for i in rhn-check rhn-client-tools rhn-setup rhnlib
rhnsd yum-rhn-plugin rhn-setup-gnome; do rpm -q $i; done
package rhn-check is not installed
rhn-client-tools-0.3.1-3.el5
package rhn-setup is not installed
rhnlib-2.2.5-1.el5
package rhnsd is not installed
yum-rhn-plugin-0.2.0-2.el5
package rhn-setup-gnome is not installed
[root@cperry NotBackedUp]# 

[root@cperry NotBackedUp]# rpm -ivh
./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm
./1/Client/rhnsd-4.5.1-1.el5.i386.rpm
./1/Client/rhn-setup-0.3.1-3.el5.noarch.rpm
./1/Client/rhn-check-0.3.1-3.el5.noarch.rpm
warning: ./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm: Header V3 DSA
signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
        file /usr/share/rhn/up2date_client/gui.glade from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/gui.py from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/gui.pyc from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/progress.py from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/progress.pyc from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
[root@cperry NotBackedUp]# rpm -e up2date-gnome
error: Failed dependencies:
        up2date-gnome >= 4.1.5 is needed by (installed) rhn-applet-2.1.25-22.i386
[root@cperry NotBackedUp]# rpm -e up2date-gnome rhn-applet
warning: /etc/sysconfig/rhn/rhn-applet saved as
/etc/sysconfig/rhn/rhn-applet.rpmsave
[root@cperry NotBackedUp]# rpm -ivh
./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm
./1/Client/rhnsd-4.5.1-1.el5.i386.rpm
./1/Client/rhn-setup-0.3.1-3.el5.noarch.rpm
./1/Client/rhn-check-0.3.1-3.el5.noarch.rpm
warning: ./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm: Header V3 DSA
signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:rhn-check              ########################################### [ 25%]
   2:rhnsd                  ########################################### [ 50%]
   3:rhn-setup              ########################################### [ 75%]
   4:rhn-setup-gnome        ########################################### [100%]
[root@cperry NotBackedUp]# 

cd /etc/sysconfig/rhn/
mv up2date.rpmnew up2date

then i could rhn_register
Comment 1 James Bowes 2006-12-14 14:12:29 EST
yum-rhn-plugin-0.3.1-2 now requires rhn-setup,
and pirut-1.2.10 requires rhn-setup-gnome.
Comment 3 Panu Matilainen 2006-12-21 01:52:16 EST
Ugh, having pirut require rhn-setup-gnome is nasty as pirut certainly doesn't
need it to function generally. Not that I can see any particularly easy way out :-/

One possibility to avoid that kinda needless dependency might be to have
rhn-setup-gnome obsolete up2date-client so it gets pulled in on upgrade, and
then have rhn-setup-gnome require pirut. It's not optimal either though. Maybe
this would be a case for anaconda-hacks...
Comment 4 Corey Welton 2007-02-07 08:33:27 EST
QA Verified that yum-rhn-plugin now requires rhn-setup and pirut now requires
rhn-setup-gnome.


[root@dhcp231-240 ~]# rpm -qa|grep yum-rhn-plugin
yum-rhn-plugin-0.4.2-1.el5
[root@dhcp231-240 ~]# rpm -qa|grep pirut
pirut-1.2.10-1.el5

[root@dhcp231-240 ~]# rpm -q --requires yum-rhn-plugin
config(yum-rhn-plugin) = 0.4.2-1.el5
rhn-client-tools >= 0.2.3
rhn-setup
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
yum >= 3.0-5.3
[root@dhcp231-240 ~]# rpm -q --requires pirut
/bin/sh
/bin/sh
/usr/bin/python
comps-extras
config(pirut) = 1.2.10-1.el5
desktop-file-utils >= 0.8
desktop-file-utils >= 0.8
gnome-python2-gconf
notify-python
pygtk2 >= 2.9.2
pygtk2-libglade
python(abi) = 2.4
rhn-setup-gnome
rhpl
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
usermode
yum >= 2.9.5

Comment 5 Jay Turner 2007-02-12 15:45:46 EST
Confirmed with 20070208.0 trees.

Note You need to log in before you can comment on or make changes to this bug.