Bug 218618 - yum-rhn-plugin needs to obsolete up2date-gnome along with up2date package
yum-rhn-plugin needs to obsolete up2date-gnome along with up2date package
Status: CLOSED DUPLICATE of bug 211540
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Bryan Kearney
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 10:09 EST by Clifford Perry
Modified: 2013-01-10 04:04 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 11:27:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clifford Perry 2006-12-06 10:09:59 EST
Description of problem:
I performed an upgrade of my laptop from RHEL 4 Desktop to RHEL 5 Beta 2 Client. 

During the upgrade process, the up2date package was replaced by the
yum-rhn-plugin. This upgrade process though failed to remove/replace the
up2date-gnome package. As such, I had to manually delete the up2date-gnome
package to avoid conflicts of files within the rhn-setup-gnome package. 

Suggest to add 'up2date-gnome' to the obsoletes of the yum-rhn-plugin package. 


[root@cperry network-scripts]# rpm -q --obsoletes yum-rhn-plugin
up2date  
[root@cperry network-scripts]# 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
[root@cperry NotBackedUp]# rpm -ivh
./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm
./1/Client/rhnsd-4.5.1-1.el5.i386.rpm
./1/Client/rhn-setup-0.3.1-3.el5.noarch.rpm
./1/Client/rhn-check-0.3.1-3.el5.noarch.rpm
warning: ./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm: Header V3 DSA
signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
        file /usr/share/rhn/up2date_client/gui.glade from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/gui.py from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/gui.pyc from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/progress.py from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
        file /usr/share/rhn/up2date_client/progress.pyc from install of
rhn-setup-gnome-0.3.1-3.el5 conflicts with file from package up2date-gnome-4.4.69-25
[root@cperry NotBackedUp]# rpm -e up2date-gnome
error: Failed dependencies:
        up2date-gnome >= 4.1.5 is needed by (installed) rhn-applet-2.1.25-22.i386
[root@cperry NotBackedUp]# rpm -e up2date-gnome rhn-applet
warning: /etc/sysconfig/rhn/rhn-applet saved as
/etc/sysconfig/rhn/rhn-applet.rpmsave
[root@cperry NotBackedUp]# rpm -ivh
./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm
./1/Client/rhnsd-4.5.1-1.el5.i386.rpm
./1/Client/rhn-setup-0.3.1-3.el5.noarch.rpm
./1/Client/rhn-check-0.3.1-3.el5.noarch.rpm
warning: ./2/Client/rhn-setup-gnome-0.3.1-3.el5.noarch.rpm: Header V3 DSA
signature: NOKEY, key ID 897da07a
Preparing...                ########################################### [100%]
   1:rhn-check              ########################################### [ 25%]
   2:rhnsd                  ########################################### [ 50%]
   3:rhn-setup              ########################################### [ 75%]
   4:rhn-setup-gnome        ########################################### [100%]
[root@cperry NotBackedUp]#
Comment 1 Bill Nottingham 2006-12-06 11:27:41 EST

*** This bug has been marked as a duplicate of 211540 ***

Note You need to log in before you can comment on or make changes to this bug.