Bug 218629 - shadow-utils does not use MD5 encryption by default.
shadow-utils does not use MD5 encryption by default.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: shadow-utils (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 10:51 EST by Peter Vrabec
Modified: 2009-11-30 09:34 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0325
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2006-12-06 10:51:59 EST
Description of problem:
System is setup to use MD5 encryption by default, but shadow-utils doesn't 
reflect it. This affects newusers and chpasswd at least.


How reproducible:
# echo "someUser:newPassword" | chpasswd
or
# echo "newUser:password:600:600:::/bin/bash" | newusers
and see /etc/shadow
Comment 1 Peter Vrabec 2006-12-06 10:57:47 EST
fix: add "MD5_CRYPT_ENAB yes" to /etc/login.defs
Comment 2 RHEL Product and Program Management 2006-12-06 11:00:36 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Peter Vrabec 2006-12-11 08:48:35 EST
(In reply to comment #0)
...
> # echo "newUser:password:600:600:::/bin/bash" | newusers
> and see /etc/shadow

newUser's password doesn't start with MD5 prefix "$1$".
Comment 5 Forrest Taylor 2007-05-11 12:54:26 EDT
This still is not in RHEL.  Could you change it to RHEL5 non-beta?
Comment 6 RHEL Product and Program Management 2007-06-05 16:48:34 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Since this
bugzilla is in a component that is not approved for the current
release, it has been closed with resolution deferred.  You may
reopen this bugzilla for consideration in the next release.
Comment 10 Daniel Riek 2007-10-03 15:49:25 EDT
Moved to 5.2 so resetting flags to ?. Keeping PM_ACK and proposal for FasTrack.
Comment 11 Daniel Riek 2007-10-05 12:49:11 EDT
Engineering feedback: shadowutils don't qualify for FasTrack in 5.2 as changes
are too intrusive.
Comment 17 errata-xmlrpc 2008-05-21 11:36:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0325.html

Note You need to log in before you can comment on or make changes to this bug.