Bug 218672 - Corruption of yum database whilst installing eclipse-platform package
Corruption of yum database whilst installing eclipse-platform package
Status: CLOSED DUPLICATE of bug 218666
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 13:20 EST by Paolo De Nictolis
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 13:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corruption of yum database (170.33 KB, image/png)
2006-12-06 13:20 EST, Paolo De Nictolis
no flags Details
rpmdb PANIC error launching yum after database corruption (1.10 KB, text/plain)
2006-12-06 13:23 EST, Paolo De Nictolis
no flags Details

  None (edit)
Description Paolo De Nictolis 2006-12-06 13:20:06 EST
Description of problem: I had finally downloaded eclipse-platform with related
packages (see bug 218666) and yum was installing packages, after "Transaction
Succeeded", when yum database were corrupted (see attached pic). Now, launching
yum, I've a recurrent PANIC error in rpmdb (see attached text trace).


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paolo De Nictolis 2006-12-06 13:20:06 EST
Created attachment 142973 [details]
Corruption of yum database
Comment 2 Paolo De Nictolis 2006-12-06 13:23:07 EST
Created attachment 142974 [details]
rpmdb PANIC error launching yum after database corruption
Comment 3 Jeremy Katz 2006-12-06 13:26:03 EST

*** This bug has been marked as a duplicate of 218666 ***

*** This bug has been marked as a duplicate of 218666 ***
Comment 4 Paolo De Nictolis 2006-12-06 16:51:14 EST
Problem is solved (temporary, since problem presehents each two-three times rpm
runs) cleaning up lock state information in the RPM db, using

rm -f /var/lib/rpm/__db* 

Note You need to log in before you can comment on or make changes to this bug.