Bug 218684 - rdesktop not redrawing/painting properly
rdesktop not redrawing/painting properly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rdesktop (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Søren Sandmann Pedersen
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 14:58 EST by Paul Krizak
Modified: 2014-06-18 05:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of an excel spreadsheet before scrolling (89.48 KB, image/jpeg)
2006-12-06 15:17 EST, Paul Krizak
no flags Details
screenshot of an excel spreadsheet after scrolling (81.78 KB, image/jpeg)
2006-12-06 15:18 EST, Paul Krizak
no flags Details

  None (edit)
Description Paul Krizak 2006-12-06 14:58:26 EST
Description of problem:

When connecting to a Windows 2003 terminal server using /usr/bin/rdesktop in
RHEL5 beta2, the screen leaves "artifacts" in various applications.  For
example, scrolling through a Word document performs the correct scrolling
action, but various bits of the screen are not redrawn properly.

Version-Release number of selected component (if applicable): rdesktop-1.4.1-4

How reproducible: easily


Steps to Reproduce:
1. Connect to a Windows 2003 terminal server
2. Open a fairly long Word or Excel document
3. Scroll quickly up or down in the document
  
Actual results:
Parts of the screen are not painted properly

Expected results:
Scrolling occurs with no artifacts

Additional info:
Using Nvidia driver version 8776 (also happens with latest 9XXX series driver,
will test with "nv" driver shortly.)
Comment 1 Paul Krizak 2006-12-06 15:04:55 EST
Using the "nv" driver, this problem does not manifest, however the performance
is positively abysmal, i.e. takes a second or more just to redraw the screen.  I
can concede that this might be an nvidia driver issue, however it should be
noted that this problem does not happen (with the same nvidia driver versions)
in RHEL3 or RHEL4.
Comment 2 Paul Krizak 2006-12-06 15:17:13 EST
Created attachment 142983 [details]
screenshot of an excel spreadsheet before scrolling

screenshot of an excel spreadsheet before scrolling, note that the row numbers
are displaying properly.
Comment 3 Paul Krizak 2006-12-06 15:18:18 EST
Created attachment 142984 [details]
screenshot of an excel spreadsheet after scrolling

After scrolling down (with the scroll wheel) several rows then scrolling back
to the top.  Note that the rows are completely garbled.
Comment 4 Paul Krizak 2006-12-14 14:41:38 EST
I found a resolution to this bug on the nvnews.net forums:

http://www.nvnews.net/vbulletin/showthread.php?t=50434

Turns out the problem is with the interaction between the Xorg server and the
accelerated nVidia driver when the "Composite" extension is enabled.  Disabling
the Composite extension fixes the issue.  However, I'm not sure if this is
something the Red Hat folks need to work on, or nVidia, or both.

To disable the Composite extension, add these three lines to xorg.conf:

Section "Extensions"
    Option        "Composite" "Disable"
EndSection

Comment 5 Ryan Daly 2007-03-08 09:03:17 EST
The redraw/repaint problem does not exist with rdesktop-1.5.0-1.i386.  I
obtained this from the FC6 updates and installed in my RHEL 5 Beta2 installation.
Comment 6 Ryan Daly 2008-03-17 15:29:45 EDT
Another work-around to this problem is (for tcsh):

setenv XLIB_SKIP_ARGB_VISUALS 1
Comment 16 errata-xmlrpc 2009-09-02 07:11:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1417.html

Note You need to log in before you can comment on or make changes to this bug.