Bug 218690 - Error message from running virt-install as non-root is non-obvious
Error message from running virt-install as non-root is non-obvious
Status: CLOSED DUPLICATE of bug 211537
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 15:28 EST by Adam Jackson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 16:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Jackson 2006-12-06 15:28:13 EST
Description of problem:

Goofy python traceback from running virt-install as normal user.

Version-Release number of selected component (if applicable):

atropine:~% rpm -qf `which virt-install`
python-virtinst-0.96.0-2.el5

How reproducible:

Always


Steps to Reproduce:
1. virt-install
  
Actual results:

atropine:~% virt-install
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 406, in ?
    main()
  File "/usr/sbin/virt-install", line 338, in main
    guest = virtinst.ParaVirtGuest()
  File "/usr/lib/python2.4/site-packages/virtinst/ParaVirtGuest.py", line 37, in
__init__
    XenGuest.XenGuest.__init__(self, hypervisorURI=hypervisorURI)
  File "/usr/lib/python2.4/site-packages/virtinst/XenGuest.py", line 174, in
__init__
    self.conn = libvirt.open(hypervisorURI)
  File "/usr/lib64/python2.4/site-packages/libvirt.py", line 39, in open
    if ret is None:raise libvirtError('virConnectOpen() failed')
libvirt.libvirtError: virConnectOpen() failed

Expected results:

What is the name of your virtual machine? 

or alternatively,

Sorry, must be root to run virt-install.
Comment 1 Jeremy Katz 2006-12-06 16:45:12 EST

*** This bug has been marked as a duplicate of 211537 ***

Note You need to log in before you can comment on or make changes to this bug.