Bug 218756 - dlm lowcomms is single-threaded
dlm lowcomms is single-threaded
Status: CLOSED DUPLICATE of bug 219799
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: David Teigland
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 06:13 EST by Christine Caulfield
Modified: 2009-09-03 12:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-12 05:31:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christine Caulfield 2006-12-07 06:13:16 EST
There is currently only a single dlm_recvd & dlm_sendd thread per machine.
On a busy SMP system this could become a bottleneck.

There should be at least one dlm_recvd thread per CPU in the system I think.
Comment 1 Christine Caulfield 2007-01-08 06:15:39 EST
A patch (for comments) has been posted to 
https://www.redhat.com/archives/cluster-devel/2007-January/msg00013.html
Comment 2 Christine Caulfield 2007-01-23 10:23:13 EST
This patch is now in Steve's -nmw tree to get further testing.
Comment 3 Christine Caulfield 2007-02-12 06:58:26 EST
This patch (with several fixes) in now in Linus' tree. It only affects the TCP
transport. SCTP is more complex and yet to do.
Comment 4 Christine Caulfield 2007-04-12 05:31:30 EDT
I'm closing this because the TCP transport is already multithreaded and the SCTP
transport parts have been amalgamated with it.

See Bug 219799


*** This bug has been marked as a duplicate of 219799 ***
Comment 5 Nate Straz 2007-12-13 12:40:47 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.