Bug 218761 - CUPS logs are chmod 700
Summary: CUPS logs are chmod 700
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-07 12:41 UTC by Stuart Winter
Modified: 2009-01-20 21:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:58:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2009:0201 normal SHIPPED_LIVE cups enhancement update 2009-01-20 16:06:07 UTC

Description Stuart Winter 2006-12-07 12:41:21 UTC
Description of problem:

/var/log/cups logs are chmod 700

Version-Release number of selected component (if applicable):

cups-1.2.4-11.el5

How reproducible:

always

Steps to Reproduce:
1. ls -l /var/log/cups

Actual results:

Logs are chmod 700 :)

Expected results:

chmod 600 would be better - having executable log files is bad.


Additional info:

It's like this because it's configured with --with-log-file-perm=0700

Comment 1 Tim Waugh 2006-12-07 13:03:29 UTC
Indeed, and this has been fixed in FC6.

Something to fix in an update I think.

Comment 4 Phil Knirsch 2008-04-30 15:40:28 UTC
Proposing for RHEL-5.3 and granting Devel ACK.

Read ya, Phil


Comment 5 RHEL Product and Program Management 2008-06-02 20:41:24 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 11 errata-xmlrpc 2009-01-20 21:58:17 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0201.html


Note You need to log in before you can comment on or make changes to this bug.