Bug 218773 - "acpi" and "apic" can't be changed by user with virt-manager
"acpi" and "apic" can't be changed by user with virt-manager
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All All
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
:
Depends On: 214361
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 09:28 EST by Daniel Berrange
Modified: 2010-10-22 03:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHEA-2007-0637
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:34:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2006-12-07 09:28:17 EST
+++ This bug was initially created as a clone of Bug #214361 +++

Description of problem:
In virt-manager, "acpi" and "apic" are always set as "1".  
In some cases, it's necessary to set "acpi" and "apic" as 0, for example a 
windows domain.  

Version-Release number of selected component (if applicable):
xen-3.0.3-0.1.rc3  
libvirt-0.1.7-2  
virt-manager-0.2.3-2.fc6  
python-virtinst-0.95.0-1.fc6  

How reproducible:
always  

Steps to Reproduce:
1.Launch virt-manager and connect to the local xen instance.  
2.Click "New" button and create a VM.  
3.The items were set as follows.  
  start up memory: 512
  maximum memory : 512
  domain name    : winsrv2k3
  virtualization method : Fully virtualized
  installation source   : /dev/hda
  disk type      : file
  disk image     : /root/winsrv2k3.img
  disk size      : 4000
  vcpus          : 1
4.Refer the configuration file under "/etc/xen".  

Actual results:
The value of "acpi" and "apic" are always set as "1" by virt-manager.  

Expected results:
The value of "acpi" and "apic" can be changed by user with virt-manager.  

Additional info:
The configuration file, "winsrv2k3", is attached with this report.

-- Additional comment from t.shirae@jp.fujitsu.com on 2006-11-07 04:35 EST --
*** Bug 214362 has been marked as a duplicate of this bug. ***

-- Additional comment from berrange@redhat.com on 2006-11-15 11:55 EST --
We don't plan to expose the 'acpi' and 'apic' settings directly through the
virt-manager UI, because no average user stands any hope of understanding what
they mean. Instead the plan is to build up a database mapping "OS type/version"
to "required set of acpi, pic settings". The wizard will then present a way to
select what OS type is being installed & automatically apply the optimial
acpi/pic settings to make it work.
Comment 1 RHEL Product and Program Management 2007-03-21 19:28:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Hugh Brock 2007-06-18 16:10:46 EDT
fixed in virt-manager-0.4.0-1.el5 (in that we allow users to choose an
os-type/os-version pair, which will set acpi and apic appropriately).
Comment 9 errata-xmlrpc 2007-11-07 11:34:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0637.html

Note You need to log in before you can comment on or make changes to this bug.