Bug 218776 - update of python-devel gives conflict
update of python-devel gives conflict
Status: CLOSED DUPLICATE of bug 218207
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 09:42 EST by John DeDourek
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 16:57:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John DeDourek 2006-12-07 09:42:22 EST
Description of problem:
"yum update" gives
Error:  python-devel conflicts with python < 2.4.4-1.fc6

Version-Release number of selected component (if applicable):
python-devel.i386 0:2.4.4-1.fc6

How reproducible:
always

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
Error: python-devel conflicts with python < 2.4.4-1.fc6

Expected results:
Successful update of python-devel

Additional info:

I am seeing a problem in attempted yum updates on an FC6 box.
It had not been updated for some time, then in the last few days
I brought it up to current, first using the default update daemon
(yum-updatesd), then disabling that daemon and using "yum update"
for more control.

However, due to the error reported, I needed to exclude "yum-devel".

Now with all other packages updated, "yum update" gives:
Error: python-devel conflicts with python < 2.4.4-1.fc6

"rpm -q python" gives:
python-2.4.3-18.fc6
python-2.4.4-1.fc6

"rpm -q python-devel" gives:
python-2.4.3-18.fc6

My suspicion is that both python-2.4.3-18.fc6 and python-2.4.4-1.fc6
should not be installed.  

A search of the "fedora-list" showed several people reporting this
problem.  Some of them suspected a corrupt rpm database, or a
problem due to an update from fc5 to fc6.  However, the box in
question was a fresh install of fc6, only the standard repos enabled,
no crashes.  Therefore, if the problem is that there are two python
packages installed, it indicates a problem with either the python
package or with yum.  A search of bugzilla gave no hits.  Therefore
I thought that this problem should be documented.

Additional information on the updates:

The "/root/install.log" is dated Nov 2 and shows the line:
Installing python - 2.4.3-18.fc6.i386

A large update was done immediately after the install on Nov 02.

A large update was done on Dec 05 under control of yum-updatesd.
A line in "/var/log/yum.log" shows:
Dec 05 16:03:08 Updated: python.i386 2.4.4-1.fc6

One unusual event during the "big update" that took place on
Dec 5 was that the root user was somehow automatically logged out
of the terminal (standard GUI login).
Comment 1 Gilles Abramovici 2006-12-21 05:23:57 EST
It also occurs with fc5
Comment 2 John DeDourek 2006-12-21 09:06:45 EST
Interesting.  This did not occur on my fc5 box, so there is some triggering
condition that initiates the problem.  A guess is that on the fc6 box, the
update to python was included in a very large update and that the update of
python interacts with the update of another rpm which caused the older python to
not get erased.

I jsut did this on my fc6 box:
  rpm -e --nodeps pthon-2.4.3-18.fc6 python-devel-2.4.3-18.fc6
The --nodeps was required because pycairo-devel depends on python-devel and
python-devel depends on python.

The yum update then proceeded successfully without the --excldue=python-devel
that I had been using.

I will report if I see any deleterious effects of having forced the erase of the
old (2.4.3) python.
Comment 3 Paul W. Frields 2006-12-21 13:39:18 EST
Confirmed this with a friend on a separate system he was installing.
Comment 4 Toshio Kuratomi 2006-12-21 16:42:31 EST
The original post leads(In reply to comment #0)
> The "/root/install.log" is dated Nov 2 and shows the line:
> Installing python - 2.4.3-18.fc6.i386
> 
> A large update was done immediately after the install on Nov 02.
> 
> A large update was done on Dec 05 under control of yum-updatesd.
> A line in "/var/log/yum.log" shows:
> Dec 05 16:03:08 Updated: python.i386 2.4.4-1.fc6
> 
> One unusual event during the "big update" that took place on
> Dec 5 was that the root user was somehow automatically logged out
> of the terminal (standard GUI login).

This is probably the issue.  It sounds as though yum was interrupted midway
through the transaction.  When that happens, yum may have installed the new
version of the package but not uninstalled the old package.

Now, you are attempting to install a new package that conflicts with the old
version that is still on the system.  You have to remove the old version in
order to upgrade.  Seth Vidal posted a script that can help with this:
  http://skvidal.wordpress.com/2006/12/04/re-wow/

Note that removing the old package may also remove some documentation files as
there's a bug in rpm that allows that.  You might want to rpm --verify the
packages have all their files afterwards and reinstall those if there are
packages missing.

The packaging bug that leads to the interrupted rpm transaction was supposedly
built today (but still needs to be pushed to the updates repo):
  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=218207
Comment 5 Jeremy Katz 2006-12-21 16:57:22 EST

*** This bug has been marked as a duplicate of 218207 ***

Note You need to log in before you can comment on or make changes to this bug.