Bug 218822 - PAE 4GB bug in hypervisor when using HVM guests with > 4 GB ram
PAE 4GB bug in hypervisor when using HVM guests with > 4 GB ram
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
Depends On:
Blocks: 218820
  Show dependency treegraph
 
Reported: 2006-12-07 13:21 EST by Daniel Berrange
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHEA-2007-0635
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:08:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2006-12-07 13:21:18 EST
Description of problem:
See upstream changeset 12732. The following is a note about it from Tim Deegan:

[quote]
>  changeset:   12732:7df4d8cfba3b2fbd12ac1f287ab854ff4b242721
>  user:        Tim Deegan <Tim.Deegan@xensource.com>
>  date:        Tue Dec 05 12:42:29 2006 +0000
>  files:       xen/arch/x86/mm/shadow/common.c
>  description:
>  [XEN] sh_gfn_to_mfn_foreign() must handle guest pfns above 4GB on PAE
>  Signed-off-by: Tim Deegan <Tim.Deegan@xensource.com>
> 
> 
> And wondered if you had any further information about the problems we'd see
> without this patch. Would it simply be psuedo-random crashes of the guest,
> or would the HV itself crash ? And is there any easy way to reproduce the
> problem for testing 

For translated PAE guests on PAE hosts, where the guest has more than
4GB of RAM, you would see memory corruption within the guest, but not
Xen crashes.  Since without Intel's map-cache patch we can't start HVM
guests with more than 2GB of RAM on PAE anyway, it's not been a problem.
The Intel developers working on the map-cache patch reported it; I don't
know what particular symptoms they were seeing.

Potentially this could cause memory corruption in translated-mode PV
guests (i.e. paravirt-ops kernels) with more than 4GB of RAM; I've not
been testing that case.
[/quote]

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2007-03-21 19:26:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Daniel Berrange 2007-06-20 11:04:16 EDT
Switching to MODIFIED since we got the patch in changeset 12732 for free as part
of the 3.1 hypervisor/qemu rebase.  
Comment 7 errata-xmlrpc 2007-11-07 12:08:57 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0635.html

Note You need to log in before you can comment on or make changes to this bug.