Bug 218836 - External NTFS HDDs are not (auto)mounted on hotplug
External NTFS HDDs are not (auto)mounted on hotplug
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 14:20 EST by Piergiorgio Sartor
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0-0.9.20070118
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 12:45:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2006-12-07 14:20:19 EST
Description of problem:
When hotplugging a storage device with NTFS partition(s), gnome-mount fails with
something like:

"The volume 'XYZ' uses the ntfs file system which is not supported by your system."

Running, from shell, "gnome-mount -d /dev/sdb1 -v -t", where /dev/sdb1 is the
actual partition of the external HDD (plugged, of course), returns:

gnome-mount 0.5
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.
** (gnome-mount:3736): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_uuid_59970BC772850F0C
** (gnome-mount:3736): DEBUG: read default option 'umask=222' from gconf strlist
key /system/storage/default_options/ntfs/mount_options
** (gnome-mount:3736): DEBUG: Mounting
/org/freedesktop/Hal/devices/volume_uuid_59970BC772850F0C with
mount_point='USB_1GB', fstype='', num_options=1
** (gnome-mount:3736): DEBUG:   option='umask=222'

** (gnome-mount:3736): WARNING **: Mount failed for
/org/freedesktop/Hal/devices/volume_uuid_59970BC772850F0C
org.freedesktop.Hal.Device.Volume.UnknownFilesystemType : Unknown file system 'ntfs'

Version-Release number of selected component (if applicable):
0-0.5.20070920.fc6

How reproducible:
Always

Steps to Reproduce:
1.
Hotplug an external storage device with NTFS partition(s)
2.
3.
  
Actual results:
Error, NTFS not supported.

Expected results:
The partition(s) should be mounted (if this is enabled in gnome-volume-manager),
in the proper "/media" mountpoint.

Additional info:
Well, after some investigation involving "hal" and "gnome-mount", I found that
the problem seems to be solvable in "ntfs-3g" (that's why the bug report is
here) by just creating a link to "/sbin/mount.ntfs-3g", within "/sbin", with
name "mount.ntfs".
That is:

cd /sbin
ln -s mount.ntfs-3g mount.ntfs

After this, hotplugging the storage device results in proper hal/gnome-mount
operation.

I do not know how "good" this solution is. Eventually it could create problems
with "/etc/fstab" entries with fstype set to "ntfs" vs. "ntfs-3g". Since the
Fedora kernel and "ntfsprogs" do not include, it seems to me, any provision for
mounting ntfs partitions, I guess this should be safe.

If there are no other problems, I would like to suggest to add the link to the
rpm package for the next release.

Thanks.
Comment 1 Piergiorgio Sartor 2007-01-19 12:37:45 EST
Hi,
any news on this side?
I saw there is an update to latest mainstream, but this problem is still there.
Did you consider to add the link (into the spec file, together with the link for
ntfs-fuse)?
I'm actually running this solution (link by hand) and I did not experience any
problem.
Thanks.
Comment 2 Tom "spot" Callaway 2007-01-19 12:45:57 EST
Sorry, I forgot to commit this fix. I've committed it to CVS, and it will show
up in the ntfs-3g-0-0.9.20070118 package.

Note You need to log in before you can comment on or make changes to this bug.