Bug 218850 - [REF] dstlimit support: libipt_dstlimit missing from iptables package
[REF] dstlimit support: libipt_dstlimit missing from iptables package
Status: CLOSED DUPLICATE of bug 198782
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iptables (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On: 218848
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 15:45 EST by Linda Wang
Modified: 2007-11-16 20:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-11 14:54:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linda Wang 2006-12-07 15:45:24 EST
+++ This bug was initially created as a clone of Bug #218848 +++

+++ This bug was initially created as a clone of Bug #208014 +++

Description of problem:
Error when trying to insert iptables rule with -m dstlimit flag. Reports
libipt_dstlimit.so missing

Version-Release number of selected component (if applicable):
1.2.11

How reproducible:
Every time

Steps to Reproduce:
1. load iptables
2. try to add rule with -m dstlimit 
3.
  
Actual results:
Error message:
iptables v1.2.11: Couldn't load match
`dstlimit':/lib/iptables/libipt_dstlimit.so: cannot open shared object file: No
such file or directory

Expected results:
Rule to load - no error

Additional info:

-- Additional comment from twoerner@redhat.com on 2006-09-26 06:05 EST --
There is no dstlimit netfilter kernel module in the current RHEL-4 kernel and
ipt_dstlimit.h in not part of glibc-kernheaders.

Please apply to kernel and glibc-kernheaders for inclusion of dstlimit, then
reapply to iptables. 
BTW: dstlimit is not part of the standard iptables build.


-- Additional comment from terryj@redhat.com on 2006-09-26 12:08 EST --
Request moved to glibc-kernheaders.

Can we get the dstlimit included in iptables? 


-- Additional comment from dwmw2@redhat.com on 2006-12-07 14:18 EST --
Not a lot of point in that unless we add the feature to our kernel.

-- Additional comment from lwang@redhat.com on 2006-12-07 15:42 EST --
There are actually two requests here:
dstlimit support in kernel, and to have glibc-kernheader headerfile for
inclusion in U6.  This bug is to track the kernel header file inclusion.
So clone this RFE for dstlimit support in the kernel, and
clone this REF to include libipt_dstlimit into iptables package.
Comment 1 Linda Wang 2006-12-11 14:54:28 EST

*** This bug has been marked as a duplicate of 198782 ***

Note You need to log in before you can comment on or make changes to this bug.