Bug 218891 - VM and a physical system that the “iostat –x” (-x returns extended statistics) that we use to gather Disk instance and statistics information is not working correctly
VM and a physical system that the “iostat –x” (-x returns extended statistics...
Status: CLOSED DUPLICATE of bug 216002
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysstat (Show other bugs)
5.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-07 19:44 EST by Christina Delahanty
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 07:53:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christina Delahanty 2006-12-07 19:44:14 EST
We have discovered on both a VM and a physical system that the “iostat –x” (-x 
returns extended statistics) that we use to gather Disk instance and statistics 
information is not working correctly.  Notice the output from the RH 4 system 
at the bottom actually returns the disk instance and statistics about the disk 
but the RH 5 does not. 

 

Output from the Red Hat 5 Beta 2 system:

 

[pukqa@rhas50-bpm-s01 ~]$ iostat -x

Linux 2.6.18-1.2747.el5 (rhas50-bpm-s01.bmc.com)        12/07/2006

 

avg-cpu:  %user   %nice %system %iowait  %steal   %idle

           0.29    0.76    0.53    0.29    0.00   98.13

 

Device:         rrqm/s   wrqm/s   r/s   w/s   rsec/s   wsec/s avgrq-sz avgqu-
sz   await  svctm  %util

 

 

Output from a working Red Hat 4 Update 4 system:

 

[pukqa@rhas40-2al-vm02 ~]$ iostat -x

Linux 2.6.9-42.ELsmp (rhas40-2al-vm02.bmc.com)  12/03/2006

 

avg-cpu:  %user   %nice    %sys %iowait   %idle

           1.26    0.00    5.38    0.04   93.32

 

Device:    rrqm/s wrqm/s   r/s   w/s  rsec/s  wsec/s    rkB/s    wkB/s avgrq-sz 
avgqu-sz   await  svctm  %util

sda          0.00  10.18  0.07  2.83    2.15  104.03     1.07    52.02    
36.65     0.00    1.39   0.86   0.25
Comment 1 Ivana Varekova 2006-12-14 07:53:29 EST

*** This bug has been marked as a duplicate of 216002 ***

Note You need to log in before you can comment on or make changes to this bug.