Bug 218916 - Spamd does not start: undefined symbol: Perl_sv_2uv_flags in /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so
Summary: Spamd does not start: undefined symbol: Perl_sv_2uv_flags in /usr/lib/perl5/v...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
(Show other bugs)
Version: 5
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-08 10:53 UTC by Yan Kuligin
Modified: 2007-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-08 15:10:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yan Kuligin 2006-12-08 10:53:15 UTC
Description of problem:
The following error occurs when trying to start spamd.
/usr/bin/perl: symbol lookup error:
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so:
undefined symbol: Perl_sv_2uv_flags

Version-Release number of selected component (if applicable):
There are spamassassin-3.1.7-1.fc5 and perl-Net-DNS-0.59-1.fc5 installed.
Both i386 and x86_64 are affected.

How reproducible:
Use /usr/bin/spamd command whithout any command line options.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Output:
/usr/bin/perl: symbol lookup error:
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so:
undefined symbol: Perl_sv_2uv_flags

There are no spamd processes running.

Expected results:
spamd is running.

Additional info:
# ldd -r
/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so
undefined symbol: Perl_croak   
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_sv_2pv_flags    
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: pthread_getspecific  
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_stack_grow      
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_form    
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_Isv_yes_ptr     
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_newSVpv 
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_sv_2mortal      
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_newXS   
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_Tmarkstack_ptr_ptr      
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_sv_2uv_flags    
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_Tstack_base_ptr 
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_get_sv  
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_Gthr_key_ptr    
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_Tstack_max_ptr  
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_newSViv 
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
undefined symbol: Perl_Tstack_sp_ptr   
(/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/Net/DNS/DNS.so)
        linux-gate.so.1 =>  (0x00eaa000)
        libc.so.6 => /lib/libc.so.6 (0x00790000)
        /lib/ld-linux.so.2 (0x00101000)

Perl packages installed:
perl-String-CRC32-1.3-3.FC5.2
perl-Digest-SHA1-2.11-1.2
perl-HTML-Parser-3.51-1.FC5
perl-URI-1.35-2.2
perl-TimeDate-1.16-3.2
perl-Net-IP-1.25-1.fc5
perl-Digest-HMAC-1.01-14.2
perl-Net-DNS-0.59-1.fc5
perl-5.8.8-4
perl-BSD-Resource-1.24-3.2.2
perl-HTML-Tagset-3.10-2.1
perl-DBI-1.52-1.fc5
perl-DBD-MySQL-3.0004-1.FC5
perl-Compress-Zlib-1.41-1.2.2
perl-libwww-perl-5.805-1.1

Also I've tried some combinations:
spamassassin-3.1.0-5.fc5.2.i386.rpm and perl-Net-DNS-0.55-1.1.2.i386.rpm - Ok
spamassassin-3.1.0-5.fc5.2.i386.rpm and perl-Net-DNS-0.59-1.fc5.i386.rpm - Ok
spamassassin-3.1.7-1.fc5.i386.rpm and perl-Net-DNS-0.55-1.1.2.i386.rpm - Ok
spamassassin-3.1.7-1.fc5.i386.rpm and perl-Net-DNS-0.59-1.fc5.i386.rpm - ERROR

Comment 1 Yan Kuligin 2006-12-08 10:59:59 UTC
The problem is gone away after rebuilding perl-Net-DNS from SRPM.

Comment 2 Mike McGrath 2006-12-08 14:21:35 UTC
# rpm -q perl spamassassin perl-Net-DNS
perl-5.8.8-5
spamassassin-3.1.7-1.fc5
perl-Net-DNS-0.59-1.fc5
# cat /etc/redhat-release
Fedora Core release 5 (Bordeaux)
# /usr/bin/spamd
[30434] info: rules: meta test DIGEST_MULTIPLE has undefined dependency 'DCC_CHECK'
[30434] info: spamd: server started on port 783/tcp (running version 3.1.7)
[30434] info: spamd: server pid: 30434
[30434] info: spamd: server successfully spawned child process, pid 30492
[30434] info: spamd: server successfully spawned child process, pid 30493
[30434] info: prefork: child states: II


WORKSFORME  - All Fedora provided RPM's.

Comment 3 Warren Togami 2006-12-08 14:24:36 UTC
ykuligin, "rpm -q perl" please.


Comment 4 Yan Kuligin 2006-12-08 14:27:21 UTC
# rpm -q perl
perl-5.8.8-4

Comment 5 Yan Kuligin 2006-12-08 14:35:34 UTC
Indeed the bug is gone with perl-5.8.8-5.


Note You need to log in before you can comment on or make changes to this bug.