Bug 218941 - Conga/luci - cannot add node to cluster via luci web app
Conga/luci - cannot add node to cluster via luci web app
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan McCabe
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 11:45 EST by Len DiMaggio
Modified: 2009-04-16 18:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 21:24:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot (296.22 KB, image/png)
2006-12-08 11:45 EST, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2006-12-08 11:45:37 EST
Description of problem:
Conga/luci - cannot add node to cluster via luci web app

Version-Release number of selected component (if applicable):
luci-0.8-25.el5

How reproducible:
100%

Steps to Reproduce:
1. Create a cluster
2. Attempt to add a node to the cluster with luci - the error shown in the
attachment results
  
Actual results:
The error shown in the attachment

Expected results:
Should add the node to the cluster

Additional info:
Nothing is written to the ricci queue or log on the node to be added to the
cluster. The debug log on the luci server includes the following:


Dec  8 10:31:38 tng3-5 luci[10005]: RC:init0: Connected to
tng3-1.lab.msp.redhat.com:11111
Dec  8 10:31:39 tng3-5 luci[10005]: RC:recv1: Received XML "<?xml
version="1.0"?> <ricci authenticated="false"
hostname="tng3-1.lab.msp.redhat.com" version="1.0"/> " from host
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:init1: Received header from
tng3-1.lab.msp.redhat.com: "<?xml version="1.0" ?><ricci authenticated="false"
hostname="tng3-1.lab.msp.redhat.com" version="1.0"/>"
Dec  8 10:31:39 tng3-5 luci[10005]: RC:authed: reported authed = 0 for
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:authed: reported authed = 0 for
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:send1: Sent XML "<?xml version="1.0"
?><ricci function="authenticate" password="password" version="1.0"/>" to host
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:recv1: Received XML "<?xml
version="1.0"?> <ricci authenticated="true" success="0" version="1.0"/> " from
host tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:auth1: auth call returning 1
Dec  8 10:31:39 tng3-5 luci[10005]: RC:authed: reported authed = 1 for
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:os: [auth 1] reported system_name =  for
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:system_name: [auth 1] reported
system_name = tng3-1.lab.msp.redhat.com for tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:cluster_info: [auth 1] reported
cluster_info = (,) for tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:init0: Connected to
tng3-1.lab.msp.redhat.com:11111
Dec  8 10:31:39 tng3-5 luci[10005]: RC:recv1: Received XML "<?xml
version="1.0"?> <ricci authenticated="true" hostname="tng3-1.lab.msp.redhat.com"
os="Red Hat Enterprise Linux Server release 4.91 (Tikanga)" version="1.0"
xen_host="false"/> " from host tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:init1: Received header from
tng3-1.lab.msp.redhat.com: "<?xml version="1.0" ?><ricci authenticated="true"
hostname="tng3-1.lab.msp.redhat.com" os="Red Hat Enterprise Linux Server release
4.91 (Tikanga)" version="1.0" xen_host="false"/>"
Dec  8 10:31:39 tng3-5 luci[10005]: RC:send1: Sent XML "<?xml version="1.0"
?><ricci function="unauthenticate" version="1.0"/>" to host
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:recv1: Received XML "<?xml
version="1.0"?> <ricci authenticated="false" success="0" version="1.0"/> " from
host tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:unauth0: trying to unauthenticate to
tng3-1.lab.msp.redhat.com
Dec  8 10:31:39 tng3-5 luci[10005]: RC:unauth1: unauthenticate returned 0 for
tng3-1.lab.msp.redhat.com
Comment 1 Len DiMaggio 2006-12-08 11:45:37 EST
Created attachment 143162 [details]
Screen shot
Comment 2 Len DiMaggio 2006-12-08 13:35:32 EST
RHEL5 GA requirement = Cluster configuration with Luci, CGA-0200 - Creating a
cluster (http://intranet.corp.redhat.com/ic/intranet/RHEL500ReleaseCriteria#Conga)

Impact statement - the user add the node to the cluster outside of Conga
Comment 3 Len DiMaggio 2006-12-08 13:37:11 EST
The text of the error displayed is:  Unable to determine the cluster OS for the
<cluster name> cluster
Comment 5 Ryan McCabe 2006-12-11 10:13:48 EST
I have a fix for this that's checked into -HEAD.
Comment 6 Len DiMaggio 2006-12-11 11:08:15 EST
That's great Ryan - can you also check on deleting a node from a cluster? It
seems to be broken too.
Comment 7 Ryan McCabe 2006-12-11 11:42:03 EST
I just checked with the latest tree (-HEAD), and it is working there.
Comment 8 Stanko Kupcevic 2006-12-13 14:25:57 EST
There is also a problem with modclusterd where it seqfaults during "add node"
action (under certain circumstances), making it impossible to complete the
operation. 

Commited to -HEAD and -RHEL5


Index: ricci/modules/cluster/clumon/src/daemon/Monitor.cpp
diff -r1.10.2.2 -r1.10.2.3
272c272,274
<   nodes.erase(find(nodes.begin(), nodes.end(), nodename));
---
>   vector<String>::iterator iter = find(nodes.begin(), nodes.end(), nodename);
>   if (iter != nodes.end())
>     nodes.erase(iter);
Comment 9 Len DiMaggio 2007-01-09 12:39:23 EST
Stan indicated that this bz was fixed in luci-0.8-26.el5/ricci-0.8-26.el5, but
it's still failing - this error is written to the luci log:

Jan  9 10:41:02 tng3-5 luci[2430]: vACN8: local variable 'e' referenced before
assignment

Is it actually fixed in 0.8.27?
Comment 10 Ryan McCabe 2007-01-09 14:52:59 EST
The fix is in -27, not -26.
Comment 11 Len DiMaggio 2007-01-19 12:51:00 EST
Verified in:

luci-0.8-29.el5
ricci-0.8-29.el5
Comment 12 RHEL Product and Program Management 2007-02-07 21:24:19 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.