Bug 218989 - /lib/lsb/init-functions should not use alias
Summary: /lib/lsb/init-functions should not use alias
Status: CLOSED DUPLICATE of bug 217566
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lawrence Lim
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On: 183952
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-08 21:59 UTC by Hugh Brock
Modified: 2014-03-26 00:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-10 10:06:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hugh Brock 2006-12-08 21:59:17 UTC
+++ This bug was initially created as a clone of Bug #183952 +++

Description of problem:
Currently, /lib/lsb/init-functions defines a number of aliases for various
lsb-mandated shell functions. This should not be done through aliases, since
aliases are only expanded when the shell is interactive.

I attach a new /lib/lsb/init-functions that implements these as proper shell
functions, and therefore works from noninteractive shell scipts; just replace
the one in the rpm with this one and everything should be fine

This doesn't just affect FC, but also RHEL

-- Additional comment from dlutter@redhat.com on 2006-03-03 20:13 EST --
Created an attachment (id=125634)
New file /lib/lsb/init-functions

Comment 1 Lawrence Lim 2006-12-10 10:06:22 UTC
Please see if redhat-lsb-3.1-12.2.EL works for you.

*** This bug has been marked as a duplicate of 217566 ***

Comment 2 Hugh Brock 2006-12-11 14:23:50 UTC
It does, thanks... sorry for the duplicate...


Note You need to log in before you can comment on or make changes to this bug.