Bug 21899 - openvt fails to work
openvt fails to work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-07 13:02 EST by Richard D. Payne
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 13:02:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "strace -v openvt top" attached (8.14 KB, text/plain)
2000-12-12 12:26 EST, Richard D. Payne
no flags Details

  None (edit)
Description Richard D. Payne 2000-12-07 13:02:14 EST
When using openvt, it always fails with a 'duplicated stdin' error. 
Printed on what
would be the new VT is:

'duplicated stdout'
'duplicted stderr'

I've tried this on 7.0 i386 and Alpha and it fails the same way on both.
Comment 1 Bernhard Rosenkraenzer 2000-12-12 12:02:45 EST
Can't reproduce this (console-tools-19990829-29).
Comment 2 Richard D. Payne 2000-12-12 12:18:47 EST
Just pulled console-tools-19990829-30 out of rawhide, still fails the
same way.
Comment 3 Bernhard Rosenkraenzer 2000-12-12 12:20:35 EST
Doesn't happen here.
Please attach the output of strace openvt.
Comment 4 Richard D. Payne 2000-12-12 12:26:33 EST
Created attachment 6292 [details]
output of "strace -v openvt top" attached
Comment 5 Richard D. Payne 2000-12-13 12:58:24 EST
FWIW, I copied over the openvt binary from a Debian-Potato system (this was
on Alpha) and their binary works fine on 7.0.

Note You need to log in before you can comment on or make changes to this bug.